jetpack-4.3 : problem installing jetson-io : L4T Debian install is not supported on your configuration


although sdkmanager failed to install jetpack-4.3 on my custom TX2 board, I installed it by using

sudo ./ jetson-tx2 mmcblk0p1

after hand-editing rootfs/etc/shadow to be able to log in as root on the serial line.

I tried to use jetson-io, but discovered it is not installed, then I discovered the .deb packages
in /opt/nvidia/l4t-packages. It seems that I must install nvidia-l4t-ccp-t186ref_32.3.1-20191209230245_arm64.deb, but that fails with a error message that I don’t find how to solve :

root@linux:/opt/nvidia/l4t-packages/userspace# dpkg -i nvidia-l4t-ccp-t186ref_32.3.1-20191209230245_arm64.deb 
(Reading database ... 119033 files and directories currently installed.)
Preparing to unpack nvidia-l4t-ccp-t186ref_32.3.1-20191209230245_arm64.deb ...
L4T Debian install is not supported on your configuration
You should install an L4T image from the latest releases - starting
from r32.3+ to have Debian package support
dpkg: error processing archive nvidia-l4t-ccp-t186ref_32.3.1-20191209230245_arm64.deb (--install):
 new nvidia-l4t-ccp-t186ref package pre-installation script subprocess returned error exit status 1
Errors were encountered while processing:

How must I fix that ?

Duplicate of, but answered in other thread.

I wouldn’t say it is a duplicate. I would be equally (and perhaps even more) happy to be able to flash my board using than using sdkmanager.

It is actually fairly simple to flash on command line. The only time SDK Manager/JetPack is required is for the extra optional package installs. If you look at your “~/nvidia/nvidia_sdk/JetPack_4.2_Linux_P3310/” (where the release version will change…thus “4.2” is bold faced font), then you will see the “Linux_for_Tegra/” subdirectory. This is the driver package (and within this the “Linux_for_Tegra/rootfs/” is the unpacked sample rootfs), and is part of the driver package.

If you cd to the “Linux_for_Tegra/” of your release, and have the TX2 in recovery mode with the micro-B USB connected, then this will flash (do keep in mind the “rootfs/” must be populated…if you ever tried to flash this will already be populated, and if not, then there will just be a README file in “rootfs/”):

sudo ./ jetson-tx2 mmcblk0p1

If your “rootfs/” is empty, and you need information on unpacking the sample rootfs, just ask. Any previous attempt to flash would have populated this and you won’t need to populate rootfs each time.

NOTE: If you then run SDKM at a later date, then you can just uncheck flash and simply add extra packages without flashing again.