Jetson AGX ORIN error missing bctfile

I’m trying to flash my Jetson AGX Orin to emulate the Jetson Orin Nano 8gb. When I run, I am getting missing bctfile error “Error: missing bctfile (/home/alex/Downloads/Linux_for_Tegra/bootloader/t186ref/BCT/tegra234-p3701-0000-p3737-0000-TE970M-sdram.dts)”. There also appear to be some other errors as well. Full log is attached below. For added context, I checked the folder the error is referring to and I have attached the list of files in that folder.
bct.txt (5.7 KB)
bcterror.txt (17.0 KB)

Hi alex380,

Are you using the devkit from NVIDIA or custom board for AGX Orin?

Error: missing bctfile (/home/alex/Downloads/Linux_for_Tegra/bootloader/t186ref/BCT/tegra234-p3701-0000-p3737-0000-TE970M-sdram.dts).

I’ve checked your log and could not find this device tree in our source.

Have you flashed the board through SDKM if you are using the devkit?

the Jetson AGX Orin dev kit from Nvidia, no custom board

Please just follow Kevin’s suggestion here to flash the board with this first. This is to debug.

Have you flash the board through SDKM if you are using the devkit?

Hi, I have managed to flash the board through SDKM to JetPack5.1 rev 1. After successfully completing the flashing, I ran the following steps (attached in log) to try to get the Jetson AGX Orin dev kit to emulate a Jetson Nano 8gb. It looks like I am getting the same error as before.
flash.txt (30.7 KB)

Does your board can boot up successfully(enter into desktop) at this moment?

Could you help to provide Linux_for_Tegra/p3737-0000+p3701-0000-as-p3767-0000.conf as file here for further check?

It is able to boot up successfully
p3737-0000+p3701-0000.conf (3.6 KB)

I mean p3737-0000+p3701-0000-as-p3767-0000.conf.

p3737-0000+p3701-0000-as-p3767-0000.conf (2.1 KB)

It’s weird that your p3737-0000+p3701-0000-as-p3767-0000.conf is expected.


I don’t know why tegra234-p3701-0000-p3737-0000-TE970M-sdram.dts showed in your flash log.

Could you help to provide the result of ls -l in your Linux_for_Tegra/ directory?
and please help to find which file containing “TE970M” in this directory.

ls.txt (5.9 KB)
jetson-agx-orin-devkit-as-nano8gb.conf (2.2 KB)

Inside the jetson-agx-orin-devkit-as-nano8gb.conf, it mentions the tegra234-p3701-0000-p3737-0000-TE970M-sdram.dts.


How did you download this BSP? Where did you get it?

it is in the section about adding support for jetson orin nano


I think there are some points here.

  1. The link you are referring to is for jp5.0.2.

  2. But so far I only saw you flash jp5.1 for your board.

The version does not match. Did you use the wrong version to apply the overlay?

Should I flash 5.0.2 then? I dont see a Orin Nano overlay for 5.1

Because there is no overlay for this release anymore… default BSP already included it…

Should I downgrade to JP5.0.2? I am unable to run the flashing command with the argument jetson-agx-orin-devkit-as-nano8gb without the Jetson Nano overlay


I don’t get your point here.

From my point of view,

  1. You filed this topic because you put the overlay into a mismatched version, which totally no need to use overaly at all.

  2. You are now telling me you cannot flash the board.

With (1) + (2)
I think the reason here is very obvious… just because you messed up the BSP here. …

So, you don’t need to “downgrade” and try a rather older method… just clean up and download your jp5.1 again and you won’t hit the issue…

The point here is just simple, if you are using jp5.1, then you don’t need to apply the overlay at all… by default it can support what you need.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.