JETSON AGX XAVIER USB2.0 mouse/keyboard not recognized

Hello, i designed a carrier board for the JETSON AGX XAVIER SoM.
in my board, i established only 2 USB2.0 (Type A) connectors.
one connected to USB0 (for recovery mode support , not tested yet) and the second connected to USB3 port - for connecting a mouse/keyboard as J507 in the JETSON EVB (USB3.1 signals are not present in my design , only differential data pair, GND and 5V power pins).
the same applies for the USB0 port.

the USB0 pins are - F12(+) / F13(-).
the USB3 pins are - G11(+)/ G10(-).

5v power to USB3 connector is created by the carrier and enabled by GPIO22.
no PD device is required in my design.

at power up, the USB device (keyboard) is recognized - " low-speed device detected " however , enumeration fails.
see attached log “log_keyboard_no_hub.txt” at [0005.827].
after a while , GPIO22 is disabled so the power to the USB3 port falls as well.
log_keyboard_no_hub.txt (30.8 KB)

i tried to connect the keyboard through a HUB (high speed…don’t have other…) and it seems that the HUB is recognized and enumerated so i don’t believe that there is a hardware problem , see attached log “log_keyboard_with_hub.txt” at [0005.657].
the keyboard is then detected but enumeration fails.
what could be the problem?

the log “log_keyboard_with_hub.txt” also shows the “dmesg” plot.
log_keyboard_with_hub.txt (162.2 KB)

thank you.
please advise.

Please find a software engineer who is familiar with device tree and refer to the AGX Xavier adaptation guide to modify the device tree first.

I notice you only talked about hardware but no software gets changed.

tegra194-p2888-0001-p2822-0000-common.dtsi (8.4 KB)

Hi,

We are working with Jetpack 4.6.
According to different answers in this forum,
we have made changes in the device tree source file:
tegra194-p2888-0001-p2822-0000-common.dtsi

Now it works.
Best regards,
Gavriel

1 Like