Jetson Nano 2G not booting

Got these from the grant program. We received 4 of them. Non will boot. There are other posts with the same issue and no mention of resolution. There is mention of using the jp460 image since it has a newer boot loader… That doesn’t work.
I connected the serial debug cable and I get the following log debug message. Interestingly the boot message is the same with SD card and no SD card. We’ve tried new SD cards, creating the SD from Windows and Linux with the same result. We are experienced creating SD cards for the Pi computer, so I don’t think its our methods, but rather a hardware problem.

U-Boot 2020.04-g6b630d64fd (Jan 25 2021 - 11:38:16 -0800)

SoC: tegra210
Model: NVIDIA Jetson Nano 2GB Developer Kit
Board: NVIDIA P3541-0000
DRAM: 4 GiB
“Synchronous Abort” handler, esr 0x96000046
elr: 00000000800e8eac lr : 00000000800978fc (reloc)
elr: 00000000fff97eac lr : 00000000fff468fc
x0 : 00000000fda2d000 x1 : 0000000000000000
x2 : 0000000002502000 x3 : 00000000fff2f000
x4 : 00000000ff800008 x5 : 0000000000000000
x6 : 00000000004a0400 x7 : 00000000fff2f008
x8 : 00000000ffff0000 x9 : 0000000000000008
x10: 000000000a200023 x11: 0000000000000002
x12: 0000000000000002 x13: 000000008019a410
x14: 000000017fa00000 x15: 00000000fff30b3c
x16: 0000000100000000 x17: 00000000001fffff
x18: 00000000fd7ffdc0 x19: 00000000fffb7940
x20: 00000000fffb7000 x21: 000000007feaf000
x22: 0000000084100000 x23: 00000000000a07d8
x24: 0000000080080000 x25: 0000000000000800
x26: 0000000000000800 x27: 0000000000000000
x28: 0000000000000800 x29: 00000000fd7fa330

Code: 17fffff1 52800123 92401c26 17fffff3 (f81f8085)
Resetting CPU …

resetting …

The SD card models also have QSPI memory, which is on the Jetson itself. Most of the time when a new SD card model fails to boot it needs the Jetson itself to be flashed. Use an Ubuntu 18.04 host PC and flash it using JetPack/SDK Manager. See:
https://forums.developer.nvidia.com/t/topic/220018/5

I can confirm using the SDK manger to install the system got the system booting. SDK manager will flash the boot loader , and install the OS drivers etc… on the SDcard from your ubuntu laptop connected to the nano via USB. Cool setup.

Once you do this resist doing an apt upgrade; this will break docker and you’ll have compatibility issues with the nvidia drivers.