Jetson nano bricked on reboot?

I downloaded the SD card image for JetPack 4.6.1 and flashed the image using etcher. On first boot, I configured the OS and got it working. I did an apt update and apt upgrade and finally did sudo reboot. The nano appeared to shutdown correctly, but never booted back up. After waiting for half an hour, I turned the power supply off and on again, but still no response. Have I bricked my nano just with a reboot command?

I have also tried using another SD card with an older jetpack but nothing happens at all. No HDMI output, no serial console. What did I do wrong? It’s damn near impossible to find a nano these days, so I really hope I can get it working again.

Generally, when this kind of error happened, it can be back alive by using sdkmanager to flash.

You think it is bricked just because you don’t know how to check the board is alive or not. Dumping the log from serial console will tell.

I want to add that “bricked” tends to mean it cannot work or be flashed again. The term basically came from PC motherboards where there was no backup CMOS BIOS, and when updating a BIOS, if something bad happened (e.g., power went out during flash), then there was nothing to do to fix this short of desoldering the BIOS and flashing CMOS in a tool for this, then soldering them back. What you’re experiencing is very likely just the video not working, but most of the system is still alive (serial console survives almost anything even if the rest of the system is failing…it is too simple to kill).

Before flashing again it would be nice to have that serial console log so it can be determined what happened. The serial console program runs on your host PC and can save a log of the boot, so it is easy to post that information from the PC. Whatever went wrong might be related to the version, so you’d also want to say what you originally flashed.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.