Jetson nano Flash emmc -> sd card

Hi. I want to flash Jetson nano emmc(P3448-0020/P3449-0000) → Jetson nano devkit(P3448-0000/P3449-0000)
What should I do?

I’ve tried

sudo ./flash -r jetson-nano-emmc mmcblk0p1
sudo ./flash -r jetson-nano-devkit mmcblk0p1
sudo ./flash -r -k APP jetson-nano-devkit mmcblk0p1

but I failed to boot.

Hi jahanda

Have you tried to flash board through NVIDIA SDK Manager?
Or you can refer to the following flash procedure
Quick Start — Jetson Linux<br/>Developer Guide 34.1 documentation

I also want to add, other than flashing through SDKM, if you do a command line flash, have you considered flashing everything (which takes barely any more time)? Example:
sudo ./flash jetson-nano-emmc mmcblk0p1

I say this because it sounds like the boot content is failing. You can’t just flash the rootfs/APP unless all other content is correct and matches the release of the rootfs.

I succeeded flash emmc to sd_card.

The reason for the failure was that I tried it with a formatted sd card.

After installing the jetpack on the sd card and upgrading the apt, I tried sudo./flash -r -k APP Jetson-nano-devkit mmcblk0p1 and succeeded.

Thank you.

Additionally, it failed without apt update and apt upgrade.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.