Jetson Nano impossible to boot

Hi everyone,

I have buy a Jetson Nano dev kit (4GB) from RadioSpare, I can’t make it boot up (juste the green light show up and nothing on hdmi / serial). I have tried the following:

  • Replace the SD card
  • change USB power supply & also try a lab power supply on jack connector
  • Change the display and the HDMI cable
  • I’ve put up a Ubuntu 18.04 machine to try to put the Jetson into recovery mode and use the SDKmanager but it’s not detected by the system on the USB bus
  • Try to see something on the serial debug, nothing show up

Someone had the same issue ??

Thanks for your help


did you set up the jumper and UART cable correctly when you want to put it into recovery mode and dump log from it?
If all of the above do not work, then sounds like you should consider sending it for RMA.


I have connected my 3.3V TTL/USB adapter to UART TX & UART RX on the J50 connector and also put the FC REC pin to the GND.

The Jetson was buy on Radiospare and it’s the second they send to me, the first one had the same symtoms … a bad batch ??

Have a good day


did you connect your UART cable correctly?
TX cable should be connected to the RX pin on the device, and vice versa.


Yes it’s exactly what I have made, with 115200 bauds 8N1 parametters.

So you try for two different devices, but still get nothing from UART? Can you take a picture of your hardware setup?

How does flashing process end? Have you tried flashing with the script tool in our BSP?

Yes it’s that, this is my setup:

Also, when I put the Jetson in recovery mode with the pin FC REC and I power it by the DC jack, when I connect the Jetson to my Ubuntu 18.04, nothing is detected by the SDK manager and nothing show up with “lsusb”


there should be multiple ttyUSBx devices under /dev/, do all of them show nothing after you power on the device? If that’s the case, then I think you do need to contact the vendor and ask them to give you a board that is guaranteed to be working.


I have tried all the ttyUSBx devices present on /dev/, also to be sure I have try to put my TTL convertor in my Windows PC and open the com port and just strange character on the moment when I put the power on the Jetson and nothing more happen…

So it would be also a deffective Jetson ?? It the second… very strange…

Check the properties of COM4 in device manager. I’ve noticed different ports on my Windows PC will report different baud rates (115200, or something else) so try that value for Speed in Putty.

I don’t think the device is working properly when neither can you enter force recovery mode, nor get any output from serial log.

Let’s get it clear again:

  1. The FC REC pin is connected to the GND pin with a jumper, but you cannot see the device with lsusb.
  2. Serial connection is established between your device and your host, with the RXD cable to the TXD oin, TXD cable to the RXD pin, but you get nothing with any of /dev/ttyx after powering on the device.
    (I think the possibility of the USB-TTL cable being broken is too low to be taken into consideration.)

Is is right?
You really should ask RadioSpare to give you a properly-working device.


DaveYYY yes it’s what I’ve try yesterday (also put RX&TX wire from my converter together to test the wiring and converter and I see character if I write so that part is good). I will contact again RadioSpare to get informations and ask for a fonctionnal board. I will try to ask if they can test the board before they ship it.

Have good day

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.