Jetson Nano - No HDMI output

I have just received a jetson nano, and flashed the image onto the sd card and plugged it into the nano. I first powered the nano with a micro usb cable and it worked fine - other than a few times the screen flashed and these weird green lines that were randomly around the screen,

I then dcided to switch to using the barrel plug as the input, with 5v and 4 amps going in. I bridged the j48 pins and plugged in the barrel plug, however after doing so I could not get any HDMI output. THe green light is on, but no screen. Even when I switch back to the micro usb cable. ANy help would be appreciated, thanks.

Hi Tommy,

Is your monitor using native hdmi port or any converter?
Does reflash the board help?


The monitor is using vga but I have an adapter to HDMI in between. I haven’t tried to reflash it, but it seems odd because this problem only occurred when i switched to using the barrel plug.

I suggest to find one monitor with native HDMI port first.

I will try that out, and give an update soon.

I have a Dell monitor with native HDMI.

I don’t hear any sound through the monitor’s speakers.

I don’t typically have this problem with Ubuntu.

Is there something that has to be installed or configured for HDMI sound output?

Are you able to see HDMI output now?

Please select the sound setting and set the audio sink to HDMI monitor.