Jetson Nano no longer displays or boots

Hi there, I recently took a Jetson Nano I was using before for the Jetbot project. I imaged everything on the sd card and put it in the Nano. It worked, and I was able to see the PiOLED, so I turned off the Nano. The next day when I tried turning it back on, it wouldn’t boot up, so I connected it to an HDMI monitor I used before, and it still displayed nothing. I tried to image the default devkit several times and still got nothing. Is there something I did wrong? I’m surprised it would be damaged by me just unplugging the power from it like that. Has this happened to anyone else?

  1. Is the LED still lit up when you powered on the device?

  2. Are you able to dump the uart log for us to check?

Thank you for your reply. The green LED turns and I checked the 5v and ground gpio pins so power doesn’t seem like an issue. I have also recently purchased a usb to ttl serial cable to check logs. Once I get that I will send that here.

Hey @WayneWWW. This is what I found:

[0000.163] [L4T TegraBoot] (version 00.00.2018.01-l4t-e82258de)
[0000.168] Processing in cold boot mode Bootloader 2
[0000.173] A02 Bootrom Patch rev = 1023
[0000.177] Power-up reason: pmc por
[0000.180] No Battery Present
[0000.182] pmic max77620 reset reason
[0000.186] pmic max77620 NVERC : 0x40
[0000.189] RamCode = 0
[0000.191] Platform has DDR4 type RAM
[0000.195] max77620 disabling SD1 Remote Sense
[0000.199] Setting DDR voltage to 1125mv
[0000.203] Serial Number of Pmic Max77663: 0x2029e2
[0000.211] Entering ramdump check
[0000.214] Get RamDumpCarveOut = 0x0
[0000.217] RamDumpCarveOut=0x0,  RamDumperFlag=0xe59ff3f8
[0000.222] Last reboot was clean, booting normally!
[0000.227] Sdram initialization is successful
[0000.231] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.237] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0000.242] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0000.248] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0000.254] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0000.260] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0000.266] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0000.272] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0000.288] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000
[0000.294] Platform-DebugCarveout: 0
[0000.297] Nck Carveout Base=0x00000000ff080000 Size=0x00200000
[0000.303] Non secure mode, and RB not enabled.
[0000.307] BoardID = 3448, SKU = 0x0
[0000.311] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.314] Nano-SD: checking PT table on QSPI ...
[0000.319] Read PT from (2:0)
[0000.334] Using BFS PT to query partitions
[0000.338] PT: Partition TBC NOT found !
[0000.342] Warning: Find Partition via PT Failed
[0000.346] BoardID = 3448, SKU = 0x0
[0000.350] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.353] Nano-SD: checking PT table on QSPI ...
[0000.358] PT: Partition TBC NOT found !
[0000.361] Warning: Find Partition via PT Failed
[0000.366] Error is 1

We received similar error from another user recently. I doubt this is really caused by just power down the device.

Are you able to flash your whole system with sdkmanager and see if issue is still?
Also, could you tell us the exact method that you did to hit this problem (if there is such method)? What was the sdcard image version ?

The SDK fixed the problem thank you! I imaged the Jetbot version 0.4.3 (JetPack version 4.5) found here: Using SD Card Image - JetBot

Then I turned on the nano with the PIOLED and turned it off after I saw it was working so I could work on it later. I probably turned it off while it could have been running something important? Hope this helps, and thanks again for your help :)