Jetson nano no sound output

How to get sound output from jetson nano?

1 Like

You may get audio output with a HDMI device (DP is eDP so no sound).
You may also use a USB audio device. I have not tried it on nano, but CM108 based adapters worked out of the box with TX2 and Xavier.

If you are using an official system image and using HDMI, you will need to go to Settings --> Audio Output to switch the output device from analog to HDMI. The default is analog audio output.

What’s the difference between DP and eDP?

https://en.wikipedia.org/wiki/DisplayPort#eDP

Can I drive an eDP display by wiring DP signal to eDP interface? What do I expect to see?

I’ve never tried, so I can’t answer. This would probably work if you had everything correctly configured (though no audio over this), e.g., EDID is passed through.

Hi all,

I’m newbie here. Also newbie with Jetson Nano :D. But I’ve worked with Ubuntu and I’ve found a way to make persistent the HDMI output configuration after rebooting the nano. These are the steps I followed to listen sound on TV by HDMI connection after rebooting the Nano:

1.- List your sound devices using this command:

pactl list short sources

2.- Identify the number that corresponds to hdmi output (0, in my case)

3.- Edit file /etc/pulse/default.pa (as root user or via sudo).

4.- Go to the end of the file and uncomment the second-to-last row and modify last word setting the number that corresponds to the hdmi device listed on steps 1/2.

5.- As non-root user delete following directory:

rm -r ~/.config/pulse

6.- If you reboot the nano you should see now the HDMI as default device.

1 Like

Hi karthikbalu.meng

Another option is bluetooth audio for the jetson nano developer kit. You must have an ePIC with bluetooth. As recommended, I tried Intel 8265NGW and it works fine

For configure the bluetooth service, see

https://devtalk.nvidia.com/default/topic/1052124/jetson-nano/nano-bluetooth/post/5351416/#5351416

I can see that my app is producing sound and both the HDMI and USB output is working but the dropdown to switch the app audio to the HDMI or USB is broken (stuck on “Built-in Audio Analog Stereo”) and does nothing.

This linux is completely broken… nothing works.

I can’t find “Settings” or “Audio Output” on my official system image. Where are they?

I don’t know enough about sound to give a definite answer, but what shows up when you list devices?
aplay -l

In particular, if you are using HDMI, then one or two of those might show something with HDMI in the named device.

From there you may want to check out this thread if it is HDMI you are working on:
https://devtalk.nvidia.com/default/topic/1004298/jetson-tx2/no-sound-via-hdmi/post/5129405/#5129405

You’d still want to list devices with aplay for non-HDMI, but I don’t know enough to actually enable this on command line.

Hi, if you are on the Jetson Nano 2GB Developer Kit and can’t get sound on your monitor, try this:
Check your session

echo $DESKTOP_SESSION

If you are using LXDE (which comes preinstalled), I recommend you download pavucontrol to change your output source.

sudo apt-get install pulseaudio pavucontrol

Then use the Configuration tab to change your Built-in Audio settings to use your HDMI output, and turn the other option OFF

3 Likes

With HDMI:
On 2GB, assuming you didn’t choose minimal option for OS installation, go to:
Sound & Video>PulseAudio Volume Control> Configuration Tab>
Built-in Audio: Profile Digital Stereo (HDMI) Output (Leave this as it is)
Change the second profile to “off” (default is on Analog)

1 Like