Jetson Nano - OEM installer failed

When booting Jetson Nano from SD Card I get these:
“Failed to start Network Manager” (many times)
“ERROR: The OEM installer failed. Your system may not be usable yet. Please report this as a bug to your vendor.”

Card was flashed using balenaEtcher with newest JetPack. I managed to see setup once (keyboard,language,timezone) but then it failed nontheless. It tried to collect logs/data and send a report automatically, but that failed too.

(“The problem cannot be reported: E:Ecountered a section with no Package: header, E:Problem with MergeList/var/lib/dpkg/status, E:The package lists or status file could not be parsed or opened.”)

I can access root by terminal though.

Hi dlech97,

Could you please describe more on how the SD card was flashed?

  1. Did you use SDK Manager to download JetPack 4.2, then manually flashed the board with balenaEtcher?
  2. Are there any error messages during flashing? If there is, can you please attach the flashing log?

Hi Edward,

I followed this guide closely:
https://developer.nvidia.com/embedded/learn/get-started-jetson-nano-devkit#write

Flashing zipped JetPack on SD card finishes without problems, but after I insert the card into Jetson Nano and power the device some errors appear:
[FAILED] Failed to start Network Manager (many times)
It hangs on “A start job s running for NVIDIA specific early first-boot script” for about 6 minutes, and final error is the one mentioned in title.
Could this be caused by power supply? I’m using 5.1V 2.5A dedicated for Raspberry Pi.

Is your Jetson plugged into the network? If so, you might try without. I have experienced stalls on first boot at various point when booting first time connected to the network (especially at unattended upgrades). Ubuntu will normally hang on boot for 5 minutes waiting for any network interfaces marked “auto” like eth0 to raise. If they don’t (waiting for an ip, for example), it can get stuck for a while. I don’t think that’s what happened here but it can’t hurt to try without network.

Hi, mdegans,
yes, I’ve tried numerous times with and without network connection on fresh OS image flashed on SD Card, yet it still outputs: “Failed to start Network Manager”, and then “A start job is running for NVIDIA specific early first-boot script” (Card stuck in programming state).
OEM came up and screen went all black.
Could the device hold some configuration outside SD Card and because of that try to setup Network Manager?
Is there a way to erase it - like factory settings?

Thanks for your response.

Huh. Can you try with another sdcard? Another power supply. Those are the next steps I can suggest. If neither of those things works it would seem to point to the Nano.

Strangely enough, different SD card solved the issue.
I was using GoodRam 32GB, then switched to SanDisk 16GB - works like a charm.

Thank you for your help!

Is there a size limitation with the SD-Card? I just had the exact same issue, and connecting a 16GB card instead of a 128GB card fixed the issue. Used the exact same process when creating both.

No, but there may be performance limitations for SDCards. SDCards from white-box/off-label brands are generally not particularly trustworthy; they may be mis-labeled, they may be over-clocked, or they may work fine for a while and then die.
SanDisk, Samsung, and the other known brand names should work fine.

To add to that, just make sure they’re actually SanDisk or Samsung. Sometimes fakes get added to the real inventory even on Amazon. it hasn’t happened to me, and I buy a lot of SD cards off Amazon, but I have heard of it happening.