Jetson Nano with PICAM360 won't boot through infinite loop on NVIDA logo

I’ve been trying to use PICAM360 camera with Jetson Nano Dev Kit which requires Jetbot and uses an older Jetbot disk image ( so as not to conflict with their firmware according to the PICAM setup instructions.

After having formatted the 64Gb MicroSD into ExFat using SD Formatter on Windows, I flash the recommended image using Etcher on my Mac (recommended to do it from Unix for whatever reason) and after successfully doing so, insert it into my Jetson Nano 4G which I’ve installed a wifi card into (just to clarify everything).

I’ve tried powering it at this point using the Micro USB as well as jumping it using J48 pins and the barrel connector, both produce the same results which is infinitely displaying the NVIDIA logo on the white background for a few seconds before going to a black screen for a few more, then repeating.

I’ve tried reflashing Micro SDs countless different ways, trying different formats, different OSs; all produce the same results.

I’ve also tried using different disk images. The first one was provided by PICAM and came with everyting preloaded including the appropriate Jetbot firmware with all the PICAM software installed as well. This failed to boot as well.

However, I was able to successfully boot into a newer disk image, although, the next step according to the PICAM instructions is to SSH into it using the command ssh jetbot@jetbot.local which can’t be reached. I’m able to SSH into it using ssh jetbot@*<jetbot_ip>* though, so it’s not unable to be connected to.

I’m also supposed to ultimately be able to access the USB picam 360 video from http://jetbot.local:9001, however, this site is unreachable as well. I am however able to connect to http://*<jetbot_ip>*:8888.

I’m new to Jetson Nano and micro-computers in general so I could be doing something stupid but I’m desperate to get this figured out. Any help is more than appreciated! I will gladly provide whatever logs would be helpful if you could simply provide me with the instructions to do so, as I’m still learning.

Thank you!

hello Karsen,

could you please check Jetson Nano – Serial Console,
please share the bootloader messages for reference,

you may check Approaches for Validating and Testing the V4L2 Driver, please confirm the sensor functionality locally with v4l2src plugin;

Any update?

Please check Jetson Nano – Serial Console,
Then share the bootloader messages for reference,

@JerryChang Thank you for your initial comment. I was able to solve the problem a few days ago and will briefly summarize for you and anyone who might happen across this:

Yes @kayccc - apologies for the late update:

I was using a custom disk image and, come to find, there is a lot that can differ in terms of flashing this image, therefore it’s best to start from scratch (ie; a fresh ubuntu install loaded onto freshly formatted SD along with ‘manually’ installing all dependencies / libraries).

Ultimately, I think the disk image I was trying to boot from was ultimately corrupted in the flashing process or before, causing it to infinitely loop. What’s strange is, one disk image was the custom PICAM image with everything preinstalled, whereas the other that would infinitely boot was an older Jetbot disk image, while the new one worked just fine. Also, the PICAM image was based on this older image, so it would make sense that neither would boot. Perhaps it was simply the outdated Jetbot image that was corrupting the boot process.

Thanks again for both of your responses.

Best wishes!

Good to know issue resolved, thanks for the update.