Jetson nano won't turn on

What kind of board level diagnostic could one perform with a never used board that will not turn on? No power LED. Using 5V barrel connector with J48 jumper set. I acquired the unit maybe a couple of months ago but so far kept in its box.

I have found schematics of the carrier board but it’s non-trivial to find out where the problem may be, unless there is some known issue or specific troubleshooting checklist…

Please follow up these guidance to setup UART debugger and share the boot log.

Interesting I’ll do that in the morning. However - I am surprised the LED DS3 won’t turn on. I have not set anything to disable auto turn-on, so I’d expect to see the power LED turn on as soon as I give it power. In fact let me check the power planes before I even continue

In fact… I only get 0.7V on the 5V pin, and that is… not nominal. 3.3V only shows few hundreds of mV. I tried with a 2.1A rated micro USB PSU (an Nvidia one in fact, well known to charge an Nvidia shield tablet fast) and also another one, different cables, same result.

I have reasons to think this board won’t give me any logs.

I have acquired another unit (through amazon this time as the price was the same) and it just works. The previous one I acquired through nvidia has any warranty with it? It’s probably something on the “mother-board”. I could try to swap the two Jetson “daughter-boards” and see if the previous one works, unless it would void the warranty or something…

Yes, that should have 1 year warranty, please try to do RMA.