Jetson NX - enable pull-up on serial port

We are currently using a Jetson NX with devkit carrier board with L4T 32.6.1.
I would like to enable pull-up resistor on uarta RX.
I followed the instruction to regenerate a pinmux config file with the pull up option enabled and successfully reflashed the board.
Here is the output of cat /sys/kernel/debug/tegra_pinctrl_reg : all 3 uart RX pins are set as 458 which correspond to
pull-up, tristate-enable, input-enable, io_high_voltage-disable

Bank: 1 Reg: 0x0c302008 Val: 0x00000458 → uart3_rx_pcc6
Bank: 0 Reg: 0x024300a0 Val: 0x00000458 → uart1_rx_pr3
Bank: 0 Reg: 0x0243d078 Val: 0x00000458 → uart2_rx_px5

I would expect each RX pin to show 3.3V on a multimeter, but every pin shows 0V. Nothing else is connected except the voltmeter. Is pull-up supported on serial RX pins? Am I missing something?

Thanks for your help!

No external pull-up is needed. If you set the port correctly, it will work then.

Thanks for your reply.
Indeed the serial port works correctly with the default configuration but we need a pull up on the RX pin as it will be attached to a component requiring a pull up. We tried adding a physical pull up with a 100K resistor and everything works, but we would like to do it directly with the internal Jetson NX pull up resistor.
Is it sufficient to configure the pinmux like I did or did I miss something? Thank you for the help!

Please do NOT change the pinmux setting for that. Since you have tested, the weak external pull-up should be OK.

OK thanks - we will keep the external pullup for now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.