Jetson NX - Raspberry Pi Hq Camera connection


I have a Jetson Xavier Nx, but it is not developer kit. It came with JNX30D carrier board. I didn’t buy from this web site but this is the example.
Link: JNX30D for NVIDIA® Jetson Xavier NX™ – Auvidea
I also have a Raspberry Pi Hq Camera. I want to use them together.

1- The camera is not compatible with Jetson. I made some research and learned I need to patch the kernel.
Link: Raspberry Pi HQ camera IMX477 Driver | Linux driver for Jetson | RidgeRun - RidgeRun Developer Connection

2- I understand that if I will patch the kernel the Jetpack options are 4.4, 4.4.1, 4.5. But I realized the Jetson I have is only compatible with Jetpack 4.6.

I researched and also tried to install other Jetpack’s it really doesn’t work with another Jetpack version.

Even if I know patches are not for Jetpack 4.6, I tried to apply anyway but it didn’t worked.

So what can I do? Is there a way to make it work?

If different carrier board works fine I can change it. But I can’t change the Jetson.

hello kevsernuryildiz,

I don’t fully understand your question.
the difference between developer kit and customize board should be on the pinmux configurations,
however, please refer to developer guide, Pinmux Changes.

If your board schematic differs from that for Jetson Xavier NX Developer Kit board, you must change the pinmux configuration applied by the software.


does this meant you could flash JP-4.6 to your target, and everything works normally?
furthermore, what’s the patches you’re mentioned?

The Raspberry Pi HQ camera doesn’t work with Jetson. But there are some steps you should follow, after that you can connect the camera to the Jetson.
1- Take out a resistor on camera
2- Do the patches. You can find them here: Raspberry Pi HQ camera IMX477 Driver | Linux driver for Jetson | RidgeRun - RidgeRun Developer Connection

Problem is there are patches for Jetpack 4.4, 4.4.1 and 4.5. But I could flash Jetson with only Jetpack 4.6. In the documentation at the link, only talkes about Jetpack 4.6 and up. Link:

So I can’t connect the camera and Jetson. I am looking for a solution to use them together.

With JP4.6 you may not need these patches, but you would have to configure IOs;

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.