Jetson Orin Nano Developer Kit overheated in idle

I recently purchased the NVIDIA Jetson Orin Nano Developer Kit and encountered some difficulties with overheating and fan issues that I would like to share with you and ask for advice.

Today, I powered on my Jetson Nano Orin and left it idle for a few hours. When I later tried to SSH into the board, it didn’t work. The USB port for debugging also seemed to be non-functional. However, the most noticeable issue was that the heatsink was extremely hot, almost to the point where touching it would burn your fingers.

I noticed that the kit’s fans didn’t appear to be working, which likely contributed to the overheating. In an attempt to address the problem, I let the device cool down and then connected it to a keyboard and monitor. Initially, everything seemed to work again, and the fans started spinning. However, after the bootloader, the screen remained black and the fans stopped. The board was still powered on, and it was evident that the heatsink was getting hotter.

I had only installed minimal software on the Jetson, mainly Jetpack, and I had updated the Python version. After that, I reflashed the Jetpack images onto the SD card using Balena Etcher. The same problem persisted - the Jetson hangs after the boot process, and the screen remains black.

Has anyone else experienced similar issues or knows potential solutions to this problem? Could there be settings or configurations that I’ve overlooked? Your insights would be greatly appreciated.

Hi mkraft,

What’s your Jetpack version in use?

Could you help to share the full serial console log for further check?

I am using the SD image ‘JP512-orin-nano-sd-card-image’. I also tried it yesterday with several different SD cards. I couldn’t get serial log via the USB debug port. I have tried using Putty on Windows, an Android app named ‘Serial USB Terminal’, and ‘minicom’ on Ubuntu. I assume that the board is broken. The screen displays ‘Attempting Recovery Boot’, after which the screen remains black .

It seems you are using SD card for Jetpack 5.1.2 (R35.4.1).

Please refer to the following instruction to capture serial console log for Orin Nano devkit.
Jetson Nano & NX Style - Serial Debug Console - JetsonHacks

Thanks for the help. I had overlooked the serial pin connections. Logs are attached. From this point on it goes no further: [ 7.502649] mmc1: new Ultra High Speed SDR104 SDHC card at address e624
[ 7.503288] mmcblk1: mmc1:e624 SM32G 29.7 GiB
[ 7.507587] mmcblk1: p1 p2 p3 p4 p5 p6 p7 p8 p9 p10 p11 p12 p13 p14 p15

LogsWin-LoadBootloader.txt (54,2 KB)

By the way Minicom did not work for me: Error opening file “/dev/modem”: file or directory not found. I switched to another program.

[    6.515132] Run /init as init process
[    6.531802] Root device found: initrd

It seems you are in recovery kernel state.
Could you interact in serial console?

Could you re-flash the board and get it recovered?

I was able to interact with the serial console and made it into EFI. It seems to show the wrong module and the wrong ram size.

I was unable to update the bootloader using the SDK manager as I am running Ubuntu 22.04 LTS which is incompatible.

Is there a simple way to update the bootloader ?

In the serial logs I sent yesterday, I found the following error
Failed to create /rm/vdd_cpu
Failed to create /rm/vdd_cpu

Can you explain what this error means? Even if the board works after the bootloader update, how can I be sure that the Jetson will not overheat again, and are there any known problems with fan control with old bootloader versions?


I have exactly the same problem. It’s a bit disappointing, as I’ve only had the device for a few weeks and used it a couple of times.

When it boots up. after the first splash scren, I can’t get into the boot manager/setup- it is completely unresponsive

It would be great if SDK Manager could be used on Ubuntu 22.04- like many people, I do not have a spare physical machine with older OS just to use this application.

Could you also clarify- rewriting the SD card is not the same as reflashing the device with SDKManager ??
In the words, to try to fix this, rewriting the SD card will not make any difference- I have to use SDKManager

thank you


Using SDKM or flash command is the simplest way to update the board.
You could also refer to the image-based OTA to update bootlodaer.

They are not the issue because the normal boot up log also having those messages.

There should be nvfancontrol service running after boot up. Is there any reproduce steps that would cause fan not working?

They are the similar operation to re-flash the bootloader, kernel, rootfs and every partitions back to default state.

ok thanks @KevinFFF

Since I’ve already re-written the SD card from image- how can I fix this problem ??

Is this your problem?
Is there the full serial console log to check where it gets stuck?

Have you tried to use SDKM on Ubuntu 18.04 or 20.04 to flash into SD card?

@KevinFFF Thanks for the help.

My problem was solved by updating the boot loader. I tried the following

Unfortunately, I could not reproduce the overheating error. I had a slow SD card on the board which caused the Jetson to hang from time to time (for several minutes). I cannot say for sure if this caused the problem.

I am happy that I can use my Jetson almost normally now. The problem with the non-existent SDKM support for 22.03 is still there. I hope that 22.03 will be supported soon and that the quality of the Jetson images will be improved.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.