Jetson Orin Nano Installation with SDKManager Doesn't Work | Stops at 37%

Hello, we recently bought an Jetson Orin Nano 8gb version. We tried using sdkmanager to flash the jetson by following instructions at the sdk manager but it sadly didn’t work.

We first installed an nvme ssd to the jetson, then we downloaded all the necessary files through sdkmanager.
We put it into recovery mode and then connected it to sdkmanager using manual setup however after installing to about 37% it just gives an error.

From what we were able to see the device is working normally and the fan is also working but the installation just doesnt work.

We’re using Ubuntu 22.04.4 LTS on a dual-booted laptop.

Here are the exported logs:

SDKM_logs_JetPack_6.0_DP_Linux_for_Jetson_Orin_Nano_modules_2024-03-15_11-03-25.zip (277.6 KB)

Do this:

minicom.zip (20.7 KB)

Make sure there is at least one USB device plugged in to the board.

I’ve got the board connected to the host pc using usb-c to usb cable.

It’s a custom board by waveshare( this ). I tried choosing both devkit & custom board but neither of them worked

Also I forgot to write here but it has a red light instead of green when I give it power, I tried looking at this post but it didn’t help solve it.

What am I supposed to do exactly? I’m lost


Here’s how its connected( the 3 cables at the bottom are from TTL to USB converter)

I tried putting it into force recovery once more but it didn’t change anything

I mean anything like a USB mouse/keyboard on the USB-A port, not just the USB-C flashing cable.

Oh thanks, I didn’t realize we needed to plug in a usb mouse/keyboard. Flashing completed successfully, thanks very much!

Sure! Glad it’s solved.
It’s a known bug in JetPack 6 DP, and a fix will be included in JetPack 6 GA so you don’t need this workaround anymore.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.