Jetson tx2-4G won't stop

Hi,
I have several Jetson TX2-4G modules mounted on connect tech quasar boards. With one of the Jetson TX2-4G modules, I have a problem. When I shut down the module (with the shutdown or the /sbin/poweroff command), the system shuts down but not the module. The led on the quasar board still indicates that the module is on. So, if I press the power button, the module does not restart. I have to do a long press to turn off and then press again to restart.
Do you think it’s a software or hardware problem?
Where should I look?
The module is new, I don’t know if it was working properly before I flashed it with my image.
Thank you,

hello paloutic,

please share the four-digit number that represents the type of Jetson module,
you may put your TX2 device enter forced-recovery mode and enter the command lsusb. the Jetson module is in Force Recovery mode if you see this message,
Bus <bbb> Device <ddd>: ID 0955: <nnnn> Nvidia Corp.

Hello,

Here is the result of the command :
Bus 001 Device 006: ID 0955:7418 NVidia Corp.
Thank you,

hello paloutic,

what’s the kernel messages shown during shutdown? you may check it by $ dmesg --follow
thanks

Hello,
I cannot read the messages while the system is shutting down. I tried to connect to the module with ssh and use the dmesg --follow command, but when I shut down the module the connection is lost immediately.
I also tried to look the kern.log file into /var/log but I have no message during the shutdown. For example, after plugged in an USB device, I shut down the module (long press on the power button) and start it again :

Mar 30 09:13:22 weederpilot0002 kernel: [  619.204852] tegra-xusb 3530000.xhci: exiting ELPG
Mar 30 09:13:22 weederpilot0002 kernel: [  619.212002] tegra-xusb 3530000.xhci: Firmware timestamp: 2018-12-26 10:30:04 UTC, Version: 55.12 release
Mar 30 09:13:22 weederpilot0002 kernel: [  619.213597] tegra-xusb 3530000.xhci: exiting ELPG done
Mar 30 09:13:22 weederpilot0002 kernel: [  619.440654] usb 1-3: new full-speed USB device number 2 using tegra-xusb
Mar 30 09:13:22 weederpilot0002 kernel: [  619.467524] usb 1-3: New USB device found, idVendor=046d, idProduct=c52b
Mar 30 09:13:22 weederpilot0002 kernel: [  619.467551] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Mar 30 09:13:22 weederpilot0002 kernel: [  619.467570] usb 1-3: Product: USB Receiver
Mar 30 09:13:22 weederpilot0002 kernel: [  619.467584] usb 1-3: Manufacturer: Logitech
Mar 30 09:13:22 weederpilot0002 kernel: [  619.541029] logitech-djreceiver 0003:046D:C52B.0003: hidraw0: USB HID v1.11 Device [Logitech USB Receiver] on usb-3530000.xhci-3/input2
Mar 30 09:13:22 weederpilot0002 kernel: [  619.678656] input: Logitech K400 Plus as /devices/3530000.xhci/usb1/1-3/1-3:1.2/0003:046D:C52B.0003/0003:046D:404D.0004/input/input3
Mar 30 09:13:22 weederpilot0002 kernel: [  619.679725] logitech-hidpp-device 0003:046D:404D.0004: input,hidraw1: USB HID v1.11 Keyboard [Logitech K400 Plus] on usb-3530000.xhci-3:1
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] Booting Linux on physical CPU 0x100
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] Linux version 4.9.140-tegra (root@TX1-DEV2) (gcc version 6.4.1 20170707 (Linaro GCC 6.4-2017.08) ) #1 SMP PREEMPT Thu Aug 15 09:42:11 CDT 2019
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] Boot CPU: AArch64 Processor [411fd073]
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] OF: fdt:memory scan node memory@80000000, reg size 16416,
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] OF: fdt: - 80000000 ,  70000000
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] OF: fdt: - f0200000 ,  85600000
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] OF: fdt: - 175e00000 ,  200000
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] OF: fdt: - 176600000 ,  200000
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] OF: fdt: - 177000000 ,  200000
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] earlycon: uart8250 at MMIO32 0x0000000003100000 (options '')
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] bootconsole [uart8250] enabled
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] OF: fdt:Reserved memory: failed to reserve memory for node 'fb0_carveout': base 0x0000000000000000, size 0 MiB
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] OF: fdt:Reserved memory: failed to reserve memory for node 'fb0_carveout': base 0x0000000000000000, size 0 MiB
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] OF: fdt:Reserved memory: failed to reserve memory for node 'fb1_carveout': base 0x0000000000000000, size 0 MiB
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] OF: fdt:Reserved memory: failed to reserve memory for node 'fb1_carveout': base 0x0000000000000000, size 0 MiB
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] OF: fdt:Reserved memory: failed to reserve memory for node 'fb2_carveout': base 0x0000000000000000, size 0 MiB
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] OF: fdt:Reserved memory: failed to reserve memory for node 'fb2_carveout': base 0x0000000000000000, size 0 MiB
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] OF: reserved mem: initialized node ramoops_carveout, compatible id nvidia,ramoops
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] cma: Reserved 64 MiB at 0x00000000fc000000
Mar 30 09:16:25 weederpilot0002 kernel: [    0.000000] On node 0 totalpages: 1006592

Is there another way to read messages while shutting down the system?

Thanks

hello paloutic,

how about use the $ dmesg --follow command, and also enable $ sudo reboot to check the shutdown logs?

Hello,
I’m sorry but I don’t understand how to achieve this.
Connected with ssh, if I do :
dmesg --follow and sudo reboot in an other terminal I’ve got :

...
[   12.841427] tegradc 15210000.nvdisplay: hdmi: tmds rate:71000K prod-setting:prod_c_hdmi_54m_111m
[   12.842876] tegradc 15210000.nvdisplay: hdmi: get RGB quant from EDID.
[   12.842884] tegradc 15210000.nvdisplay: hdmi: get YCC quant from EDID.
[   12.881536] extcon-disp-state external-connection:disp-state: cable 47 state 1
[   12.881541] Extcon AUX1(HDMI) enable
[   12.881644] tegradc 15210000.nvdisplay: unblank
Connection to 192.168.0.31 closed by remote host.
Connection to 192.168.0.31 closed.

If I do it on the module, it’s the same thing, I have no time to see anything.
I think that I don’t understand what to do. Can you explain a little bit more ?

I made some video during module’s shut down. Here a screenshot :

hello paloutic,

could you please have a try to configure log rate limiting in Linux,
please have a try to completely disable systemd journal logging rate.
for example,
/etc/systemd/journald.conf

#RateLimitIntervalSec=0s
#RateLimitBurst=0

you may restart the systemd-journald service to apply the changes.
i.e. systemctl restart systemd-journald

please try above and share the results.
thanks

Hi,
Does not change anything, same behavior as before. Here is a screenshot :

I just realized that if I shut down the module with the power button (short press), as I said it before the system shut down but not the module. Then, the module reboot itself after 180 seconds.

Thanks,

hello paloutic,

could you please remove the kernel config to disable the watchdog by sysfs.
for example,
kernel/kernel-4.9/arch/arm64/configs/tegra_defconfig

- CONFIG_WATCHDOG_NOWAYOUT=y

BTW,
is this issue only reproduce on the specific one? since you have several Jetson TX2-4G modules mounted on connect tech quasar boards for testing.
thanks

Hi,
I need more help to to this. I don’t find the tegra_defconfig file to change the value. Could you be more specific ?

Yes, this is the only Jetson TX2-4GB module with this problem. I tested it with different quasar board and the same problem happened.

thanks,

hello paloutic,

please check Kernel Customization for the documentation to setup environment and building the kernel image.
you’re able to access L4T sources for the public release source-code.

suggest you should also contact with your vendor, (i.e. ConnectTech) for further support.
thanks

Hello,

I don’t think this is a problem with the quasar boards. I tested the Jetson TX2-4GB (with the shutdown problem) module with 3 different quasar boards and each time I have the same problem.

Currently, I have 10 Jetson TX2-4GB modules and 10 quasar boards, and only one Jetson TX2-4GB module is giving me problems.

All 10 modules were flashed with the same system image.

I don’t understand why for one of the modules I should make changes to the kernel when everything works perfectly for the others?

Is it possible that it is a hardware problem?

Thanks,

hello paloutic,

thanks for giving feedbacks, it looks like a hardware problem there.
are you able to arrange hardware resources to probe the signal?
please access Jetson TX2 Series OEM Product Design Guide and check [Power Sequencing] for reference,
thanks

Hello,
I made some measurements. I don’t known how to access all measurements points on the board so I started with simple one : POWER_BTN# and RESET_OUT#.

  1. Board connected to power : POWER_BTN# = 4 V ||| RESET_OUT# = 0 V
  2. power button press : POWER_BTN# = 0 V (for 400 ms) ||| RESET_OUT# = 0 V and RESET_OUT# = 1.8 V after 100 ms
  3. system started : POWER_BTN# = 4 V ||| RESET_OUT# = 1.8 V
  4. system shutdown : POWER_BTN# = 4 V ||| RESET_OUT# = 1.8 V

So RESET_OUT# voltage never returns to 0 V.
Does it help ?
Thanks

Hi, do you have a devkit to verify if this issue can happen on devkit carrier? It looks like a hardware issue since other modules are OK. If so, you can run RMA for it.

Hi,
I just have a TX1 devkit. Is this compatible with the TX2-4GB module ?
Thanks,

Yes if it is P2597 board.

Ok thanks, I will try soon.