Jetson Xavier NX developement board healdess issue

Hello, I need a little help with the setup of NX board. I have downloaded nv-jetson-nx-sd-card-image-r32.4.2.zip from the website, wrote it on an SD card, booted the board with it.

I can see the NV Linux for Tegra device on my host with the micro-USB connected, also I can use screen through the ttyACM device, but all I get is a login prompt. According to the docs its supposed to be a setup process for the device.

Can anyone shed some light here what am I doing wrong?

Ok looks like it is working on a Windows host, I do not know why is it important what OS the host is running, but now I’m getting the initial setup screen.

ttyACM should not give your a login prompt but the setup. Could you paste what you’ve seen here?

I’m getting an identical issue. First boot (well, second, but I didn’t do anything the first time). screen /dev/ttyACM0 prompts for login.

The host mounts a drive (L4T-README) over USB as expected.

I don’t know the login credentials. nvidia/nvidia doesn’t work. Going to attempt to re-flash with the sdkmanager.

Also, the module is heating up and the fan isn’t turning on. This is concerning to me – is this expected behavior?

What I’m seeing:

localhost login: nvidia
Password:

Login incorrect
localhost.localdomain login: ^C
Ubuntu 18.04.4 LTS localhost.localdomain ttyGS0

We got similar report on another thread. It looks like an issue that only happens to sdcard image.

Still checking.

Did you use Linux or Windows as host to connect Jetson NX? Seems you use Linux host. I ran into a similar issue with minicom in Linux host, but then it works just fine if I use putty from Windows host.

I’m now using putty from Windows and getting the same behavior. Also used putty on Linux, same behavior. I get a login prompt.

At this moment, it is too late to use either putty or minicom. You need to re-image SD card, reboot, and then once the Serial Port show up in Windows Device Manager use putty to connect, then you will see the setup prompt.

So it’s really a “one shot” process? That’s rather unforgiving.

I didn’t see any mention of the requirement for putty+Windows for setup to work. It would be nice to see the docs updated. Thanks for your help, I’ll reimage and see how things go.

No, this is really a bug. We don’t have anything that is supported only on Windows.

All our test environment is on Linux. As I said, we are still checking.

Thanks. In the meantime, Windows / Putty worked and I got far enough through the setup process to get an account I can login with. After the step that created the account, the Putty connection dropped (I’m not sure why and I don’t remember what was on the screen when setup failed). But the Jetson seems to be working fine.

Except the fan doesn’t spin. Is it expected behavior for the fan to not spin? I don’t want the device to overheat.

Hi kakukz493,

We don’t hit this issue with r32.4.2 sdcard image on Xavier-NX.

  1. Using Etcher tool to flash r32.4.2 image on sdcard
  2. Plug-in micr-usb cable (J5) and power (J16) on Xavier-NX
  3. After power on the device, check host machine:
    $sudo picocom -b 115200 /dev/ttyACM0
    -> start oem-config setting, after setting completed, open the /dev/ttyUSBx to login. (please connect TX/RX/GND pins)
    The login username and password is setting from oem-config without issue.
1 Like

Please confirm

Plug-in micr-usb cable (J5) and power (J16) on Xavier-NX

I am not sure what to confirm here, that I plugged the micro-USB cable into J5 and the power adapter into J16? Yes I did.

Also for the screenshot part since we only have 1 board, and my colleagues using it I’m gonna need some time when I can reflash and make screenshots. But I got the same Linux login prompt evanmt03s pasted into his comment.

What we wanted to point out is when you use micro usb as power source, this function of /dev/ttyACM0 seems has problem.

Thus you must use power adapter as dc supply.

It is normal the serial console dropped at the end of setup. You now need to use putty to login 192.168.55.1 which is the IP address via the MicroUSB-to-USB connection.

To clarify…
When not in recovery mode, the MicroUSB port will show up as 3 devices on the host… a ttyACMx serial port, a virtual usb ethernet port, and a usb hard drive. In headless setup mode, the setup dialog shows up on ttyACMx. When the setup completes. the device re-initializes which is why the connection to ttyACMx drops. If you connect again to ttyACMx you should get a standard Linux console. And… as @Colin mentions there will also be a private network set up between the Jetson and your host.

1 Like