Jetson Xavier NX unable to boot, but power led turns on


I have recently been facing an issue where my Jetson Xavier NX is unable to boot up, but the power led turns on. I tried connecting over serial using the J14 pins to see the kernel log to see what happened, but all I am able to see is garbage output. It was repeatedly turned on and off prior to the booting issues and since then nothing besides the power led appears to work correctly. The display output, USB, and ethernet appear to not be working. Has anyone faced this kind of situation? Any advice or assistance on this matter is greatly appreciated!


You probably don’t have the baud rate set correctly in your terminal emulator. Try setting it to 115200.

I already checked that, I tested the exact same setup on another xavier and nano I have and it worked perfectly fine. I only cannot connect with jetson that does not boot, not sure why yet

That’s odd. Not even seeing the early output from the bootloaders?
I’d take a look at all of the pins on the carrier board and module to make sure there’s nothing that might cause a power drain and disconnect all other peripherals including USB devices and any front panel LEDs and switches and see what happens.

Hmm yeah, unfortunately. Like there is an output on the serial console, but it is all garbage - which is why I initially thought it was a baud rate issue, but after testing with the other boards it didn’t seem to be the case :( I’ll try taking a closer look at the pins on the carrier board and see if anything seeems off