I try to flash jetson orin nano with default username and password with L4T_create_default_user.sh.
And run flash command. But after success flashing the device, no default user created.

Did you use sudo with the “l4t_create_default_user.sh” program? If not, then that would be a problem. Also, did you perform a normal flash via JetPack/SDK Manager? Or was it a command line with something unusual like an initrd flash? If the latter, then it might be that the script was applied in a place that does not go to the correct boot device.

I didn’t use sudo previously, after using sudo it’s still not creating user after flash.
then I tried with create new user with --accept-license args and it’s work.

Do you know how to delete created user and give sudo privilege to user?

I’m not positive of the meaning of the question. If you are talking about someone who is logged in to the Jetson, then the script you mention would create an account which is an admin account (meaning that the account will be in the sudoers file). One can only alter that file with special methods, otherwise the system will shut everyone out of sudo. However, that file is basically a recipe for making certain commands (or all commands) available. The “l4t_create_default_user.sh” script adds the account, and it adds the account to the sudoers list.

If you actually log in to a Jetson, then be careful about deleting users. If you were to do so, then you’d use the userdel command (see “man userdel” on a system with the man pages, e.g., the host PC).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.