Light shape visible through refraction

Is there any way to completely turn off light visibility so it won’t appear behind the refractive objects?

Found a workaround by disabling Specular multiplier from the light parameters, but now I am obviously loosing all its specular contribution…

Hello @karol.osinski! I’ve asked the dev team for some assistance. They should be replying shortly!

1 Like

@karol.osinski In the soon-to-be-release Kit 104.0 version, we will have a setting in the Common render settings allowing masking secondary rays (reflection and refraction) of lights which are set to ‘Visible In Primary Ray = False’ if a surface’s roughness is below a user-defined threshold.

This way you could still see your emissive light mesh fixture in the reflection and refraction, while the invisible light would only be sampled at higher surface roughness values where necessary for fast convergence/sampling.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.