Looking for Python IDE to run on Jetson Nano

I’m running a Python ML code and is freezing the entire Jetson Nano environment. The same app runs without problem on MacOS.

Want to debug on Jetson Nano and looking for a GUI debugger.

Tried to install Visual Studio Code but it seems to not be working as it keeps showing over and over again the ‘install’ just after finishing the installation.

Any luck here?

No luck with PyCharm either, it doesn’t have a package for arm64.

Update: Actually PyCharm works on my Nvidia Jetson Nano arm64. I did

apt-get install openjdk-8-jdk

then downloaded the Linux version of PyCharm community from their website, extracted the files and

cd pycharm-community-2019.1.1/bin
./pycharm.sh

This started the installation process and it worked well.
Give it a try. I love PyCharm.

2 Likes

I also got it to run, took it a little further with a native fsnotifier (great for performance) and some hack for the desktop icon.

Hi,
I was able to install Pycharm in my nVidia Jetson nano.The issue is with installing OpenCV in Pycharm. It says it cannot find a version.

Can somebody help me with this?

When i looked for help in Google,most of them suggested to update pip which i have tried.But still the same error.

thanks and regards
Vamshi Krishna

I tried the steps above and it is working beautifully.

Following the suggestions above, I was able to install and run pycharm on the jetson nano, but then was not able to install openCV in the pycharm project. like @vamshikrishnadr96 says above, I get error that no package is found. In fact, I could not add any libraries to the projects opened on the nano.

Would really like to hear if anyone has been able to set up a good python IDE on the jetson nano.
Thanks!

This works for me! Thx!

Downloading, Extracting and Installing the Pycharm archive (tar) on the Nano worked. Thanks!

Pycharm:
https://www.jetbrains.com/help/pycharm/installation-guide.html#standalone

Maybe you need to use an older version of python because the newest one it isn’t supported by pycharm yet.