LUKS Encryption Password Screen not Showing

-I am having this issue on both Ubuntu and Fedora distributions.
-I am currently running Fedora 37. After I installed the NVIDIA drivers (v 525.89.02) to use instead of nouveau, when I boot my computer, it passes the GRUB menu and then shows a black screen where I would typically see a splash screen with a password prompt to decrypt my hard drive.
-I can type my decryption password and press Enter and a few seconds later, I will see the splash screen that shows after a successful password entry. The system then boots normally to the login prompt.
-If I reboot instead of booting “cold”, the password prompt screen will show.

Razer Blade 15 Advanced (2022)
GeForce RTX 3060 GPU

Attached is my dmesg output.

bootlog.txt (104.4 KB)

still having this issue.

I suspect this is a fedora 37 specific kernel bug.
Since you have an optimus system, the internal screen is driven by the intel igpu, the nvidia gpu should have no influence on this.
Furthermore, the nvidia driver doesn’t get embedded into the initrd so only loads when you unlock your system (after 110s in the log).
Another user had a similar issue and found out he only got a console when removing both
nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init
from kernel cmdline.
Please check and possibly report a bug with fedora.

That user was me.

In fact I was able to switch to TTY3, etc…

While I was looking for a solution for my problem, I also found a lot of issues regarding LUKS encryption. Mostly it as possible to just enter you password, even if the dialog is not shown.
In case this does not work, try to remove

nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init

from the kernel parameter in grub.

When grub is shown, select the entry you want to boot and instead of “RETURN” press “E”
then from the line starting with



nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init

It could be possible that the entry is in front and after

rhgb quiet

remove both.

Then, to finally boot the kernel, press “CTRL + X”

Also take a look at bug report for rpmfusion:

Thanks for the suggestion, however that did not work. Perhaps what generix was saying is true and the NVIDIA drivers do not have anything to do with this.
Attached is my bootlog after doing what was suggested.
boot.txt (103.9 KB)

Do you have the same issue with nouveau driver?

I do, which probably validates I need to consult with Fedora.
Will probably delete this post alltogether. Thank you guys for the time.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.