Materials synced from Substance Painter to Unreal Engine are just bright white

I have tried the Substance Painter Connecter, that works quite well, props for that! When I add the Unreal Engine 5 connector into the mix, I’m currently not able to proceed. All the matierials in UE5 are coming up as bright white.

Am I missing something, or is there a bug somewhere?

Basically what I would expect is this:

However that doesn’t seem to work anymore.

When you’re linked between Substance Painter and Create, the Create Painter Link Extension will use local files from on-disk to ensure the most rapid texture updates. This is accomplished through an in-memory session layer inside Create. When you access the USD model (and materials + textures) from Unreal, everything will come from a Nucleus server. Do you have the Nucleus Submit box checked to ensure that every texture update is sent to Nucleus?

Here’s a link to the section in the Substance Painter Connector docs that describes the Nucleus Submit checkbox:
https://docs.omniverse.nvidia.com/con_connect/con_connect/substance-3d-painter.html#nucleus-options

Hi @LouRohan

The Nucleus Submit box is checked, the textures are synced via Nucleus, I double checked that.

However the material inside Unreal Engine 5 doesn’t link to the textures, once I manually reference them in the material instance that was assigned to the object, then it starts working.

This is the Material Instance:

This is where the Material Instance is stored apparently:

Thank you @3dpxl. Will look into this.

Hello @3dpxl I see your image of what you would expect. It doesn’t look like you have any emissive properties in your texture in Create but in your Unreal image it shows an error for the emissive color property.

Do you have the emission channel enabled inside your painter project?

Would it be possible to share your fbx and or painter file to look at?

Thank you.

I found the solution to this problem: We have to selected the “UE4 template” when creating the Substance Painter file. If that is not the case, it will simply not work, even though the “Texture Export” preset is set to Unreal Engine 4.