UE 4.26.1 not connecting to nucleus

Hi there,

I’m wondering if anyone can help me out here, I’ve followed the tutorial here: Intro to Omniverse Unreal Engine 4 Connector | NVIDIA On-Demand

Unfortunately when I press Omniverse Add server this is the result:

I’m really not sure why this is happening, I followed the tutorial on Maya connector and that seems to be working properly (Maya actually takes me to an online browser and I get to log-in etc), UE doesn’t do that, just gives me the error.

Thanks!

That’s strange, if you can ping mechspiderovtest, then you should be able to connect to it in Unreal. Can you enable the developer logs from the Omniverse Project Plugin settings and send us the project logs?

Okay so I’ll give you as much info as possible to try and help me! I appreciate it :) Trying to use Omniverse for my next project, I come from VFX heavy background so I’m not an expert at Unreal just yet. Dividing this into multiple posts as I can only link 3 times per post.

I tried to load an existing project called RobotScene that has a USD plugin enabled https://i.gyazo.com/23a6ae93cce15b74859c238e7559b34d.png

When doing so, the Omniverse plugin experiences a problem and gives me multiple errors like this:

The last error in that sequence that pops up is:

Right, you cannot have both Epic’s USD Importer plugin and NVIDIA’s Omniverse plugin enabled at the same time. We’re working on making this possible, but due to USD linkage issues it’s not possible yet.

The unreal scene doesn’t open, and it goes straight back to Epic Launcher.

The way I’ve fixed this temporarily is by going to my G:\UE_4.26\Engine\Plugins\Editor and deleting the NVIDIA folder, this allows me to get back into the project and turn off USD importer:

Once I’ve turned off the USD importer plugin (And restarted, then closed my project)
Then doing the following:
Omniverse Launcher > Exchange > Connectors > Epic Games Unreal Engine 4.26 Omniverse Connector > Install

Back into G:\UE_4.26\Engine\Plugins\Editor\NVIDIA

Once that’s done I can open the project normally without any problems.
The first thing I notice though, is that I have Omniverse plugin available:

To finish my notes on the issue:

I do not see Omniverse folder, although in your tutorial you see it when you open the project.

That’s what I see when I open the project.

When I use the plugin to “Add server” it works for just a moment but then gives the error:


Thanks for unflagging my posts, not sure what happened there :)

Here is the log file you asked for:

I think the log I sent you didn’t include the part where I tried to use Omniverse, here is the excerpt:

[2021.04.02-20.18.42:756][ 0]LogLoad: (Engine Initialization) Total Blueprint compile time: 0.00 seconds
[2021.04.02-20.18.42:756][ 0]LogInit: First time updating LLM stats…
[2021.04.02-20.18.42:767][ 0]LogDisplayClusterInputModule: DisplayClusterInput device has been initialized
[2021.04.02-20.18.43:045][ 0]LogContentStreaming: Texture pool size now 1000 MB
[2021.04.02-20.18.43:092][ 1]LogAssetRegistry: Asset discovery search completed in 24.8503 seconds
[2021.04.02-20.18.43:095][ 1]LogCollectionManager: Fixed up redirectors for 0 collections in 0.000005 seconds (updated 0 objects)
[2021.04.02-20.18.43:158][ 2]LogSlate: Took 0.000949 seconds to synchronously load lazily loaded font ‘…/…/…/Engine/Content/Slate/Fonts/Roboto-Light.ttf’ (167K)
[2021.04.02-20.52.46:884][123]LogSlate: Window ‘About NVIDIA Omniverse USD and MDL Plugins’ being destroyed
[2021.04.02-20.56.59:581][388]LogSlate: Window ‘Add Omniverse Server’ being destroyed
[2021.04.02-20.57.03:156][699]LogSlate: Took 0.001133 seconds to synchronously load lazily loaded font ‘…/…/…/Engine/Content/Slate/Fonts/Roboto-Light.ttf’ (167K)
[2021.04.02-20.57.05:500][919]LogOmniverse: Connecting server omniverse://testserver…
[2021.04.02-20.57.07:845][146]LogOmniverse: Connect to server omniverse://testserver failed…
[2021.04.02-20.57.10:929][440]LogUObjectHash: Compacting FUObjectHashTables data took 1.35ms
[2021.04.02-20.57.10:970][440]LogSlate: Window ‘Message Log’ being destroyed
[2021.04.02-20.57.10:974][440]LogSlate: Window ‘RobotScene - Unreal Editor’ being destroyed
[2021.04.02-20.57.10:975][440]LogWindowsTextInputMethodSystem: Display: IME system deactivated.
[2021.04.02-20.57.11:123][441]Cmd: QUIT_EDITOR
[2021.04.02-20.57.11:124][441]LogCore: Engine exit requested (reason: UUnrealEdEngine::CloseEditor())

Hi hugh6,
Please removing omniverse.toml at C:\Users\YOURUSER\ .nvidia-omniverse\config and retrying to connect your server.

Hi JulianC1,

I just tried this and I get the same result. Tomorrow I will have a brand new computer, so I will test all this again with a new system and see if the problem presists.

Thanks,

Hugh

When I use my localhost server, I can access it through a web browser using this address: http://localhost:8080/ .

I assume that “testserver” is a valid machine name on your network that is running a Nucleus server. Can you access testserver through the web Nucleus browser client?

We are really confused that Maya and UE4 are giving you a different connection experience. They use the same client library, so you shouldn’t see any differences.

Are you putting just the machine address in the “Add Omniverse Server” dialog? We’ve had issues in the past where people put “omniverse://ov-sandbox” in there, and it doesn’t yet work (I plan on fixing this soon…):

image

Okay! This was the problem, in the tutorial I followed there wasn’t clear direction on exactly what to put in the Add Omniverse Server!

In Maya this happens pretty automatically, I never had to put localhost:3009 in there, but in UE4 you have to put your full localhost server name, and I did this after running the Drive. So it’s working now!!! Thanks guys for investigating this, I figured it was something simple I was doing wrong, just wasn’t sure exactly what!

I will let you know if I run into any other troubles, can’t wait to show you guys our progress on the animation cinematic and how we use Omniverse :)

Thanks,

Hugh

NICE! I’m glad you figured it out. Might I ask what you were putting into your “Server” field? This is just so I can make this dialog box as friendly as possible in the future.

Note, the docs show a picture like the one here in the forums, but I know there’s a lot going on, so it’s easy to miss stuff.

To be honest I was putting the project name in there thinking “Add server” meant you are creating a new server based on the name you input, I didn’t realize it wants me to connect to existing server.

Thanks again for your help!

I found that in order to see the folder you need to go to View Settings and check “SEE EMPTY FOLDERS”

1 Like

Ouch Man Hours And Hour trying to locate the answer ! THANK YOU YOU NEED TO TYPE localhost dear god!
please for the love of all things put a red colored word that says type localhost…