Omniverse Server failed to connect

Hello! I have unreal engine ver 4.24.3
I have installed the Omniverse Create ver 2021.1
I have also installed Omniverse Unreal Engine connector for UE 4.24 ver 101.1

Now I follow this video tutorial:

When I press Omniverse/Add Server I get error:

Omniverse Server pekan-servo failed to connect.

I have all programs running. What might this be?
I do not get the folders automatically created as in the video.
I also think this might be the reason. In my UE content browser inside the folder “Omniverse” I do not see the sub-folder localhost. So could not create my server to there…

I wonder why I do not have that folder there?


I also tried the same with UE 4.25 and Omniverse Connector 4.25
The same error:

Please help if anyone can?

Pekko, I assume you are using the local Nucleus server, or “Collaboration Service”. In the “Add a server” dialog, try putting the text: “localhost”. You should also be able to access your local Nucleus server from your browser (assuming you installed the Collaboration service from the Omniverse Launcher) from this URL: http://localhost:8080/

In the next hotfix, coming within the next few weeks, I have autofilled in the string “localhost” to relieve confusion around this issue. You’re not the first person to have this struggle.

Thanks or the answer Lou!

Yes, I use the Nucleus Collaboration Service. Here:

But in my UE editor 4.25 I see only this when I hover over the Omniverse icon:

KInda empty…
But hey anyway your trick worked out man! Yes.

It connected to Nucleus, asked my login details too :)
And now it looks like the tutorial video I am following. Great!


Now as this connection works, I see that the thumbnails for my assets are not created in Omniverse Create.

But in the Omniverse/localhost/NVIDIA/Samples/Marbles/assets/standalone/RT_elevator/

They are visible, mostly:

Why is this?

@pekka.varis - Thumbnail generation is a preference setting.
Edit->Preferences. Look for this:

Thank you Mirice! I ticked the option you showed. Then I greated a new project and dropped in some USD objects. But no new thumbnails appeared…

Except for the Project itself:

But the asset folders for the assets ( imported UE project with Omniverse Connector 4.25 ) are still not created:


Hey, I got an error while saving my scene:

Maybe this is the reason I cannot see my assets thumbnails ?