Mellanox MCX555A-ECAT Packet Pacing problem

Recently I use cards Mellanox MCX555A-ECAT (100Gb/s)

I am using Freebsd 13 (head), recently decided to use the Packet Pacing option, but was surprised to find that following the instructions from the manual:

To enable Packet Pacing in firmware:

  1. Create a file with the following content:

vim /tmp/enable_packet_pacing.txt MLNX_RAW_TLV_FILE

0x00000004 0x0000010c 0x00000000 0x00000001

  1. Update firmware configuration to enable Packing Pacing:

mlxconfig -d pci0::0:0 -f /tmp/enable_packet_pacing.txt set_raw

  1. Reset the firmware:

mlxfwreset -d pci0::0:0 reset

Packet Pacing is not activated.

I have several servers, so I did several tests on different cards and the same result.

Firmware on my cards:


I tried a different version of the driver and the 3.5.0 and 3.5.1 results are the same. Packet Pacing is not activated.

How fix this?

Hello Iliya,

I don’t see support for your configuration as the FreeBSD MOFED driver is for ConnectX-3 & ConnectX-4:

Are you using the inbox driver?

Many thanks,


Yes, i’m using this driver [base] Revision 347325