Missing /home/nvidia/drive-t186ref-linux

I seem to be missing: /home/nvidia/drive-t186ref-linux on target but I do have it on my host machine.

Thank you.

Please provide the following info:
Software Version
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.4.0.7363
other

Host Machine Version
native Ubuntu 18.04
other

Hi @mae25 ,

I just checked that my setup has no the problem.
Did you install/flash DRIVE OS 5.2.0 with SDK manager and your NVIDIA Developer account? Could you try to flash it again? Thanks.

I did flash with SDK manager and my account. I will try flashing again…

Thanks

I re-flashed with DRIVE OS 5.2.0 with the same result. Should /home/nvidia/drive-t186ref-linux be on the target after this step? Or after installing Driveworks?


Screenshot from 2021-02-09 10-38-15

Please share the file referenced by ~/.nvsdkm/sdkm.log. We would like to check the log of your installation. Thanks.

I believe it is this one:

sdkm-2021-02-09-08-58-41.log (175.9 KB)

Is there any file/directory under below path on your host system? Have you select OpenDDS in “Additional SDKs” during installation?

~/nvidia/nvidia_sdk/DRIVE_OS_5.2.0_SDK_Linux_OS_DDPX/DRIVEOS/drive-t186ref-linux/targetfs/home/nvidia/drive-t186ref-linux

~/nvidia/nvidia_sdk/DRIVE_OS_5.2.0_SDK_Linux_OS_DDPX/DRIVEOS/drive-t186ref-linux/targetfs/home/nvidia/ is empty. No I did not select OpenDDS during installation… Should I?

Then it is expected. Only OpenDDS selected, some samples will be included in the path.

BTW, those samples mentioned in NvMedia Sample Applications are available in ~/nvidia/nvidia_sdk/DRIVE_OS_5.2.0_SDK_Linux_OS_DDPX/DRIVEOS/drive-t186ref-linux/samples on host system and you can follow Building and Running the NvMedia Samples to cross compile them.

Not installing OpenDDS was my issue, thank you.

1 Like

What about the /nvavb/daemons which are on the host but not the target after flashing?

Thank you.

Just copy them over?

ie copytarget?

I get this output when attempting copytarget-samples:

sudo ~/nvidia/nvidia_sdk/DRIVE_OS_5.2.0_SDK_Linux_OS_DDPX/DRIVEOS/drive-t186ref-linux/utils/scripts/copytarget-samples /home/nvidia/drive-t186ref-linux/

===============================================================================
Disclaimer: CopyTargetv1.3 and earlier versions including this BASH script will be deprecated in DriveOS 6.0 release.
CopyTargetv1.4 and subsequent versions, which are Python and YAML format will supersede this script.

cat: /home/nvidia/drive-t186ref-linux/etc/passwd: No such file or directory
cat: /home/nvidia/drive-t186ref-linux/etc/passwd: No such file or directory

I haven’t tried the script. Please directly scp the files to your target system. Thanks.

From cross-compilation - drive-t186ref-linux missing - #3 by ahuef

It is required to select flashing the board in sdkmanager to setup cross compiling setup on host. Then you will be able to see drive-t186ref-linux folder on host. Installing just on host does not install the required cross compilation setup.

Right, I did select flashing the board. Just unsure the correct way to transfer to the target (I tried with the ‘copytarget-samples’ script unsuccessfully). But can certainly just use scp.

Thanks,

Marc

I ran the command and then flash again with SDK Manager. It will be on the target system.
But you can just directly scp cross compiled binaries to target system.

$ ~/nvidia/nvidia_sdk/DRIVE_OS_5.2.0_SDK_Linux_OS_DDPX/DRIVEOS/drive-t186ref-linux/utils/scripts/copytarget-samples ~/nvidia/nvidia_sdk/DRIVE_OS_5.2.0_SDK_Linux_OS_DDPX/DRIVEOS/drive-t186ref-linux/targetfs

Can you please explain that? Ran the copy target command on the host and then re-flashed to get it to transfer?

After running the command, binaries will be part of the root file system and then be flashed onto the target.
But I would suggest you to just ignore the command and use “scp”. Thanks.