Monitor Configuration not saving

I’m running Ubuntu 20.04 with a GEFORECE RTX 2070s graphics card. Since getting a new monitor, my computer has had issues with the resolution and other settings when logging out or restarting the computer. When initially logging back in, everything appears correctly for a couple seconds before both of my monitors go dark, then come back with the primary display (the new monitor, which should be at 2560x1440) being disabled entirely and my secondary monitor (which should appear at 1920x1080) coming back at a severely reduced resolution and refresh rate.

I’m able to restore the proper setting using the “NVIDIA X Server Settings” app, but despite trying to save the settings to the X Config File after making the changes, none of them stick around after being logged out. I’m aware that sometimes there’s a permissions issue with the x config, so I tried a method where I saved the new xconfig somewhere else and used it to overwrite the old one with the command line, but that didn’t seem to fix it either.

I’m about out of ideas, any recommendations are appreciated, thanks.

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

I don’t seem to be able to upload the file. I changed the permissions to get it out of read-only mode, but the post still will not allow it. I’m fairly inexperienced with Linux still, so apologies if I’m missing something

Attaching a file to your post shouldn’t be Linux dependant, maybe you’re trying to upload a different file?
nvidia-bug-report.log.gz

I’m able to upload image files, text files, and pretty much everything but the file I need to upload. I even moved it into a different folder in case my browser wasn’t able to access it for whatever reason. I’m able to select the file, but when I click “Upload” I get the message “Sorry, there was an error uploading that file. Please try again.”

It’s definitely not the wrong file

What size is it?

417 kB

I also tried running the command again to produce a new file, but that one is giving the same error

If you have internet connection, you can use pastebinit to upload it from console.

  • install pastebinit (sudo apt install pastebinit)
  • unzip logfile (gunzip nvidia-bug-report.log.gz)
  • upload logfile (pastebinit -i nvidia-bug-report.log)
  • note down and post the url you’re given

Right so I managed to install pastebinit and unzip the file, but when I tried to upload it I got the “HTTP Error 502: Bad Gateway” error. I do have an internet connection, I’m using the same computer to post this and I’m streaming from Spotify at the same time.

Try using another pastebin: https://help.ubuntu.com/community/Pastebinit

Are you in some kind of retricted network or behind a proxy?

Home network, no proxy, and vpn is disconnected.
I tried “cat nvidia-bug-report.log | pastebinit” and got the same error

Try restarting your router.

nvidia-bug-report.log (3.3 MB)
Okay so turns out I can upload the file after it’s unzipped. Restarting the router didn’t work, but here’s this

Looks like a intermittently flakey hdmi cable:

 nvidia-modeset: WARNING: GPU:0: Unable to read EDID for display device VIZ E28h-C1 (HDMI-0)

That monitor gets re-detected quite often.

That’s not the monitor that’s having issues and the settings only ever reset once per login and it’s always after about 2 seconds. It’s possible that the cable is bad, too, but there’s no reason that would be the cause of the config not saving.

Edit: Also worth noting that that monitor is an old smart TV so it kind of makes sense that it would give some weird output

Worth noting is that on boot, no monitor was detected at all, then suddenly both monitors and lots of input devices show up. Are you using a KVM switch?
For testing, please unplug the HDMI cable, this seems to trigger the mode switching.

@bryanwillings long shot but in my experience nvidia settings runs as user but to save settings needs to be run as root. You can force it to run as root from your menu by doing this: https://askubuntu.com/a/1324099/68396

Will try the force root and HDMI later tonight when I get the chance, thanks for the tips