My Jetbot will no longer boot with the GUI enabled

This first part was my original post

I am new with the Jetbot pack for the Nano and was trying to fix the wi-fi connection. It only occasionally finds a wlan0 source on boot, so I have to reboot it 5-6 times to be able to use it with Jupyter.
To that end, after turning off power saving for the wifi and blacklisting rtl8192cu, I tried using the driver solutions I saw in the forums.
From https://github.com/pvaret/rtl8192cu-fixes I typed

echo options rtl8xxxu ht40_2g=1 dma_aggregation=1 | sudo tee /etc/modprobe.d/rtl8xxxu.conf

into my terminal and then rebooted the system. I was going to do the rest of it after that, but ever since my screen has gone black after the first Nvidia logo and a few lines of text.
It can still boot, it still connects to the wi-fi occasionally, and when it does I can still access the Jupyter lab module on my computer. But I cannot see my screen on my jetbot, which had previously worked perfectly, and I can’t seem to get to the terminal blind, which I was trying to do afterwards.
I have the Ubuntu 18.04 default gui as my current interface.
This is the text that appears after the Nvidia logo and before the screen goes black.

I have now found that I can start it up fine and reach the terminal if I disable the GUI again. It did work at one point but no longer does. If anyone has ideas on how I can diagnose my GUI issues and fix them I would deeply appreciate it!

Hi kweber1022,

Thanks for reaching out! The latest JetBot SD card images, as well as docker setup instructions, both actually disable the GUI to conserve memory (since JetBot is programmed over WiFi and does not need the Ubuntu GUI).

It may be the case that this is why the GUI is not appearing, (but possibly not if you are using an older JetBot SD card).

If you’re able to connect to JetBot via Jupyter Lab, you might be able to try the following to re-enable the JetBot GUI:

  1. Connect to JetBot over Jupyter Lab

  2. Open a new terminal

  3. Install ssh

    apt update
    apt install ssh
    
  4. SSH into the JetBot host (since the terminal is currently inside the docker container). Use password jetbot

    ssh jetbot@0.0.0.0
    
  5. Re-enable the Ubuntu GUI

    sudo systemctl set-default graphical.target
    
  6. Reboot the JetBot

Please let me know if this helps or you run into issues. If you don’t think these instructions apply to your issue, please let me know.

Best,
John