Nano 2GB boot looping

Hello all

Got my first Jetson Nano 2GB today

Flashed up the SD card etc

After powering on i get a NVidia logo which either stays up and does not change
or seems to reboot after about 20-30 seconds

Tried 2 different SD cards, 2 Power supplies (and ones that have worked perfectly with raspberry pi 4)

Any suggestions? LED does not seem to give any hints


Few things here

  1. Stuck in NV logo means the boot up process cannot go into kernel. Dump the log from serial console can tell us what is getting stuck.
  1. If you don’t want to dump log, then you can try sdkmanager.


looks like if i try the sdkmanager method i can use usb rather than serial?

No, they are doing different things.

Sdkmanager -> flash the board with SDK and driver through usb (similar to sdcard but different method) -> If you still hit same error, you have to dump the log from serial too.

Just make it easier to understand.

Flashing the board through usb is a method that supports for every jetson platform since tk1.
SDcard is a new method that starts from jetson nano and NX.

Hello, I had a similar problem. I discovered that I was using the 4GB Jetson Nano image for the SD card. You have to use the correct image for the 2GB Jetson Nano (both links are on the Nvidia developer site)


Thank you kind person!