Nano freezes on Nvidia logo

Hi there,

I have a Nano 2GB - model number 945-13541-0000-000

I have downloaded the SD card image from here;

I have used etcher to write the image.

When the Nano boots it shows the Nvidia Logo and freezes. After a minute, it goes black and then re-displays the image.

I have seen a lot of posts where this happens. It is usually;

  1. The wrong image.
  2. Only some SD cards appear to work.
  3. The power supply is too small.

So, I would be super grateful if someone could confirm that the image above is the correct image.

Meanwhile I will try a bunch of different SD cards.

Tried different cards - made no difference.

So frustrating, you think this would be easy as it is the first experience anyone has with the product.

Probably not card issue. Reason in point 0. Please try with sdkmanager.

You can also dump the log from serial console so that we can check what is going on.

Thank you for you response.

If I even understood a quarter of what you posted, I probably would not need to post.

I apologise for wasting everyone’s time.

Maybe you could retitle “Getting started with Jetson Nano” to - “Getting started with Jetson Nano once you are fully familiar with Ubuntu and have a spare Ubuntu computer available to debug your Nano when it fails to boot”.

But, just in case… can you answer the question I asked? Am I using the correct image?

Yes, that should be the correct one.

If you suspect that is wrong, you can check here for different of sdcard image.

But I think this issue comes from something else. So need the debug log.

Tried the different image - no luck.

OK, so just to make the Nano work, I have to;

  1. Find another computer.
  2. Install Ubuntu 18.04 on it.
  3. Install the SDK Manager.
    4 Find a USB to TTL serial cable.
  4. Put the nano into recovery mode.
  5. Reflash something.
  6. Get a log.
  7. Stick it on the forum and hope for a result.

And you say; “This one is common so let me put it here.”.

I think I’m going back to my Pi!

Dump log and installing are two different things.

Dumping the log is to analyze your current error.

Reflashing with sdkm may just resolve current error and not necessary to dump logs.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.