NGC Private repository is empty

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.4 (rev. 1)

Target Operating System

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)

SDK Manager Version

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers


I’m trying to download the docker for cross compilation from NVIDIA NGC , however the private repository never loads.
I have got the welcome email and accepted it.
Please, see picture attached.
Can you please help me with this topic?


Dear @NikolayChernuha,
We are looking into it and update you.

Hi, I managed to see the repository internals, by switching between tabs couple times all containers → organization… → … → all containers.
However now I have another problem.
When I want to connect to cli or connecting thru docker I get rejected.
Please take a look:
Using CLI:

ngc config set
Enter API key [no-apikey]. Choices: [<VALID_APIKEY>, ‘no-apikey’]: my-private-key
Enter CLI output format type [ascii]. Choices: [ascii, csv, json]: csv
Enter org [no-org]. Choices: [‘drive’]: drive
Enter team [no-team]. Choices: [‘driveos-sdk’, ‘no-team’]: driveos-sdk
Access denied retrieving ace list.
Enter ace [no-ace]. Choices: [‘no-ace’]: no-ace
Successfully saved NGC configuration to /home/nikolaychernuha/.ngc/config

Connecting with docker:

docker login
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post “http://%2Fvar%2Frun%2Fdocker.sock/v1.24/auth”: dial unix /var/run/docker.sock: connect: permission denied

In password section I type the password from the setup page.

So, basically the question is now: why don’t I have access to the repository?

Thank you,

Dear @NikolayChernuha,
Does sudo docker login works? also the username has to be $oauthtoken . Please see Set Up Docker and NVIDIA GPU Cloud Access

Hi, I tried couple more times and it just worked. I saw someone else on the forum that did the same.
Here is the link to that thread: Unable to log into docker account - #7 by Morganh

Dear @NikolayChernuha,
Thanks for the update.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.