Missing ngc private repository permissions to pull driveos-sdk after joining NVIDIA DRIVE® AGX SDK Developer Program

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04


I created an Nvidia Account and joined the Drive AGX Developer Program through NVIDIA DRIVE® AGX SDK Developer Program | NVIDIA Developer. A mail was sent confirming “Your application to the program NVIDIA DRIVE® AGX SDK Developer Program has been approved.”.

Unfortunately at https://catalog.ngc.nvidia.com/ there is no entry “Private Registry” and docker pull ends with an error message:

docker pull nvcr.io/drive/driveos-sdk/drive-agx-xavier-linux-aarch64-sdk-build-x86:     
Error response from daemon: pull access denied for nvcr.io/drive/driveos-sdk/drive-agx-xavier-linux-aarch64-sdk-build-x86, repository does not exist or may require 'docker login': denied: requested access to the resource is denied

My user profile shows me listed in following programs:

I appreciate any help,

Hi @maximilian.birkner
Please see if Drive AGX Docker Container not available helps. Thanks.

Thanks for your reply, as you can see in the attached screenshot no mail from NGC was sent to my account (junk mail is empty as well). Is there another way to join this group?

Please check if the email with “Welcome to NVIDIA NGC” subject was received. Thanks.

I’m sorry, no mail with that topic arrived. Is it possible to remove myself from the group and rejoin the program? The thrash bin in the user profile is a link to your contact formular and does nothing.

I didn’t know you create this topic with your gmail.
just double confirm that you search “Welcome to NVIDIA NGC” mail in your company mails instead of gmail, right?

Hi @VickNV,

yeah, I also tried to get access with another account, but it did not get approved (yet). No welcoming mail was received in any of my mail accounts. You can be sure I dit not miss the mail in spam or anything like that.

Update: Another colleague tried to get access with his company account and the welcome mail was not sent again. The prebuilt drive-sdk images would accelerate our development workflow a lot, so any help would be gladly appreciated.


I’ll check with our team and get back to you. If possible, please also share me the company email of your colleague via private message.

We just received welcome mails, thanks a lot for helping out!

Thanks for the update. I’ll let our team know.

BTW, may I know if your colleague also received the email?

Both of us received them at the same time:-)

Got it. Thanks.