Nonsense with high CPU / GPU usage

What is this nonsense with extremely high CPU / GPU usage when the scene is completely empty?

There is nothing to render at all and yet my laptop is loud and getting hot for no reason.

I am not rendering, simulating or otherwise doing anything that would justify any CPU / GPU use at all, let alone having it high that I would need ear plugs to tolerate that.

How to make it right?

Hi @b.zarzycki1 - I would request to provide important details such as your setup, Isaac Sim version, log file, screenshot of what you are seeing.

Hardware:
Gigabyte Aero 15 with RTX 3070
Intel i7
32GB RAM
1TB SSD

Software:
2023.1.0
Windows 10

When the scene / render is completely empty or blank I see a lot of CPU / GPU consumptions, even when I haven’t press ‘Play button’ on the left hand side.

In terms of ‘logs’ I don’t know where should I look for them.

you should be able to locate the Isaac Sim log here (in the respective version subfolder) - C:\Users\%username%\.nvidia-omniverse\logs\Kit\Isaac-Sim

How far back the logs should go ?

the most recent .log file should do, unless the mod asks from an older session.

kit_20231102_215311.log (1.2 MB)
kit_20231102_215830.log (1.9 MB)
kit_20231103_113933.log (1.2 MB)

window → script editor
run

import carb
carb.settings.get_settings().set("/app/show_developer_preference_section", True)

edit->preferences ->developer

you can set various settings to throttle and limit fps when in focus/out of focus

if you want to permanently change settings you can open
apps/omni.isaac.sim.base.kit
and edit these three lines

[settings.app.renderer]
skipWhileMinimized = false
sleepMsOnFocus = 0
sleepMsOutOfFocus = 0

by default Isaac Sim runs as fast as possible and doesn’t throttle

This reply will be split due to single screenshot limitation

Changing the settings like so…

…made it tolerable to the point that it brough in some confidence that my system is not going to fry itself while what should be idling.

While previously I got at least of of the CPU’s core maxed out, now it is more where it should be, that is no more than 2/3 of the full.

Besides, I don’t need to have 60, or 120, FPS because I can reasonably get away with 25 FPS to just have a good view what is going on in the simulation. Everything above that is placebo FPS and not needed, especially if the on the flip side the cost could be ‘frying’ CPU, GPU and over heating internal SSD when not achieving or doing anything - idling.

Thank you for your advice.

However, it seems that all the settings are gone whenever I restart the Isaac Sim or the whole OS (Windows).

@b.zarzycki1 the settings are only persistent if you edit apps/omni.isaac.sim.base.kit
or even with changing the settings here you see them reset when you restart isaac sim?

We are working on a better solution for the next release that decreases perf when not playing so when isaac sim is sitting idle, resource usage is low.