Not able to log in to DRIVE Xavier

Hello,

I am not able to log into Drive Xavier anymore. After I turned it off last time and turned it on today, the default password for the nvidia account does not work anymore. If I try to log in for a Guest session, I just see the blank green-black default screen and nothing else happens.

Is there a solution for this issue?

Thank you

Hi david.freund,

By default GDM (GNOME Display Manager) is configured to auto login with “nvidia” user.
Have you changed anything on your system? Can you login remotely through ssh?

Dear david.freund,

Could you please connect Drive Xaiver via ssh from host pc and run “sudo dpkg --configure -a” and re-check it? Thanks.

Thank you

I did not change anything on the system since I used it the last time.

It is not possible to start a terminal on the drive using ctrl+alt+f1/2/3/…, the screen just turns off when I try that.

If I check the IP by connecting another laptop to the ethernet and try to connect to the IP using nvidia@ip on the host machine I get the error “ssh: connect to host 10.85… port 22: Connection refused”.

Dear david.freund,

If you can’t connect to DriveAGX via ssh, could you please try to connect DriveAGX with minicom tool like below?
If yes, I guess you will get the DriveAGX IP address.

sudo minicom -D /dev/ttyUSB2

I connected using minicom and got the IP.

When I connect via ssh and run the “sudo dpkg --configure -a” command I am still not able to log in. Also after a reboot I get to the same login screen and my password is not accepted.

Dear david2,

Could you please re-flash the system if possible? Thanks.

Thank you for your answer.

I tried to reflash the Drive but got an error when flashing the OS. Everything goes well until the Flash step. The Error is:

09:23:03 ERROR : Flash Xavier A+B in parallel :
09:23:23 INFO : Flash Xavier A+B in parallel : Host OS platform Debian Stretch/Sid is not supported
09:23:23 INFO : Flash Xavier A+B in parallel : Supported OS's are : Ubuntu 16.04 XenialUbuntu 14.04 TrustyUbuntu 18.04 Bionic

The host machine is running ubuntu 16.04 LTS, therefore I don’t know why I get the error.

Hi david2,

Could you install the latest release (DRIVE Software 10.0) via SDK Manager on ubuntu 18.04? If any installation issue, please create a separate topic for it. Thanks!

Here is the download page of the release: https://developer.nvidia.com/drive/downloads

You can run below command on the target system to check the status. If it’s inactive, you need to fix the problem.

$ sudo service ssh status