Drive AGX Xavier does not start up

Dear NV,

Drive AGX Xavier does not start up. (The fan on mainboard doesn’t work)

Tried following steps:

  1. Disconnect all power supply and devices from Xavier main board
  2. Waited 20mins, 30mins, overnight
  3. Connect the power, reboot
  4. still does not start up (fan doesn’t work)

Drive Software 9.0

Dear vincent.zou,
Is it a new board or it was working fine with DRIVE Software 8.0 and facing this issue after after flashing DRIVE Software 9.0?

Dear NV,

More detailed as follows:

  1. Xavier reflash to SW9.0, working properly for about 2-3 days.
  2. One of engineer backup data via network to NAS, but failed with error notice.
  3. He tried USB port again but Xavier A failed to recognize the USB device.
  4. Then he reboot the Xavier but failed, from that time, Xavier never can boot again.
    a. Tried disconnect all the cables, devices including display, failed
    b. Tested the power supply output, 12V output showing properly, external power supply should has not issue.
    c. Fans on Xavier never response, only 3 LED lights turned on once connected with external power supply and turned power on.
    d. MCU Switcher in ‘run’ status instead of ‘PRG’
    e. Linux PC can’t detect the Xavier, tried reflash, error as attached.
    f. Tried sudo minicom -D /dev/ttyUSB3 & USB2, couldn’t connect.

Dear vincent.zou,
Could you please a bug with all these details and share bug ID here.
Also, please attach pictures of blinking LED lights along with S/N details.

Dear vincent.zou,

Could you please help to check if the power connection part on harness cable is connected properly like below? Thanks.

Attached photo with LED lights.

Dear NV,

Cable is properly connected.

Dear Vincent.zou,
Is this unit in car or at desk?

It’s in office, at desk.

Dear Vincent.zou,

Could you please try to re-flash the Aurix FW with below link?
Since ttyUSB’s don’t work you will have to unplug the debug USB and use the Aurix UART connector on the harness.

https://docs.nvidia.com/drive/active/5.1.0.2L/nvvib_docs/index.html#page/DRIVE_OS_Linux_SDK_Development_Guide%2FFlashing%2520Basics%2Fflashing_aurix.html%23

Hi Steve,

We re-flashed the Aurix FW via UART connection, it works.

Problem solved, issue closed.

Thanks a lot for your support.