Now Available: NVIDIA DLSS 3 for Unreal Engine 5

I am happy to share with you:
The long awaited DLSS 3 integration package for Unreal Engine 5.2 is finally ready! Check out our detailed blog post on the topic!

Hello, I tried out the new DLSS plugin in VR on 5.2 and while DLAA works, setting the screen percentage below 100 causes it to crash like in the previous version. Does there happen to be a solution for this?

Assertion failed: InVelocityTexture->Desc.Extent == FIntPoint(1, 1) || InVelocityTexture->Desc.Extent == InSceneDepthTexture->Desc.Extent [File:C:\BuildAgent\work\206b5a556ada38bf\_Stage\Plugin\Plugins\DLSS\HostProject\Plugins\DLSS\Source\DLSSUtility\Private\VelocityCombinePass.cpp] [Line: 102]

UnrealEditor_DLSSUtility!AddVelocityCombinePass() [C:\BuildAgent\work\206b5a556ada38bf\_Stage\Plugin\Plugins\DLSS\HostProject\Plugins\DLSS\Source\DLSSUtility\Private\VelocityCombinePass.cpp:102]
UnrealEditor_DLSS!FDLSSSceneViewFamilyUpscaler::AddPasses() [C:\BuildAgent\work\206b5a556ada38bf\_Stage\Plugin\Plugins\DLSS\HostProject\Plugins\DLSS\Source\DLSS\Private\DLSSUpscaler.cpp:503]

Update: Started trying to debug it myself and the issue seems to be in Unreal Engine itself. The InSceneDepthTexture->Desc.Extent and InVelocityTexture->Desc.Extent are being mismatched due to the InSceneDepthTexture->Desc.Extent specifically not updating its size on screen percentage change.

Currently, other upscaling like FSR and tsr end up causing a visual glitch where the viewport itself shrinks for distant landscape / meshes without being upscaled to the full resolution, so it appears in a weird box at the top left of the left eye view, making it unusable.

DLSS is just checking for this bad state early and exiting the application instead of letting it render that weird result. Commenting out the check in DLSS results in the same behavior as the others due to the mismatched extents.

Going to try and figure out a fix in the unreal engine codebase tomorrow…

Hello there @coldbomb1, welcome to the NVIDIA developer forums!

Great to hear that you already tried the new release out.
A word of caution, VR support is not something that could be prioritized so far, see also this ongoing thread. That means people’s success does vary.


The plugin for Unreal Engine has now been updated for engine version 5.3.

Check out and find it as an additional download option.

I’m unsure what is happening or if I’m missing anything here… The plugin for 5.2 works perfectly fine I’m reaching 60/70 fps but the 5.3 seems to do nothing, everything works fine as far as the plugin is activated, allowing usage of nodes, etc. but as far as “effect” seems to do nothing.

UE5.2 60/70 fps

UE5.3 fps cut half or less and seems to do nothing in terms of effect

Update : On Editor without playing it, it shows the “boost” from DLSS (I activated it in settings to activate on editor as well) but soon I “play” fps and performance drops straight away… Is this issue UE5.3 Engine or the plugin for UE5.3?

Hi @phantasywave and welcome to the NVIDIA developer forums!

Could you please open a separate topic for this issue? That way we can track it more easily.

And while you are at it, could you attach your UE logs please, including when you start the project in Play mode?

Thank you!

1 Like

Sorry about that I will work on the new topic now, thank you for getting back to me.

Update : opened a new topic, if anyone could help the link will be here for the topic.

Thank you

DLSS 3 for UE5.3 issue - Engines / Unreal - NVIDIA Developer Forums

Hello still waiting to see if someone could have a look into my topic, pretty sure the fix will come out as an easy fix but for the moment I’m not being able to find it myself, thank you and sorry to bother