Nsight error - Value cannot be null. Parameter name pSrcNativeVariant

My operating system is windows 8 64 bit
Graphics card is GeForce GT 650M
I am using cuda version 5.5

I installed nsight with visual studio 2012. Before opening a project if I try to access Nsight properties everything works fine. But once I open any project and click on any of the options in the Nsight menu, an alert pops up saying “Value cannot be null. Parameter name pSrcNativeVariant”.

Can anyone please help me?

Hi,

Do you mean that prior to opening any project, you select the Nsight menu items without a problem? Since you don’t have an opened project, you won’t be able to execute many of the commands (from the Nsight menu), can you select System Info? Does the Nsight monitor run?

What type of project do you open? Are you able to reproduce it with the samples that ship with Nsight?

Thanks

The Nsight monitor runs and I was able to access all the options before I opened any project(as in at the start screen of visual studio). I opened normal C++ project and Cuda project. It did not work for either of them.

I encountered exactly the same problem. After trying many things, I found this problem could be simply solved by just running the visual studio in the administration mode once. Under the admin mode, run the nsight debugger, then the problem is solved. Admin mode is not required later. At least this works for me, good luck to you.

xythnvdevtalk, interesting data, thanks for sharing. We are not aware of any requirements to run VS as admin first, but will definitely check it out to see if there’s anything we can do about it.

Bharadwaj-Akella, could that be the reason why you see the problem? If you are able to run VS as admin, could you try that and see if it fixes your issues?

We’ll try it out on our end as well.

Thanks

Hi,

We tried this and could not reproduce: After installing VS 2013 on a clean Win8.1 machine (without any VS) and after the VS installation we didn’t click the launch button but just exit.
Then, installed Nsight 4.0, opened a project in VS 2013, go to Nsight menu-> Option. Change settings and save. No errors were seeing.

If you have any other detailed information on how we can reproduce and fix this issue, please let me know.

I don’t know how to reproduce the error. It happens occasionally at the beginning. But it is fixed automatically if clicked the debugger for several times. Later, this trick does not work. So cannot say what’s going on here.

Another thing is that, once the error occurs, I cannot even open the “Options…” in the “NSight” menu, which returns the same error. So I guess it is an error of integrating the NSight with the IDE.

The error happens again. This time everything I tried before did not work.
Finally it is solved in this way:
“I fixed this by deleting the visual studio solution user options file (.suo).”

Interesting. Thanks for letting us know.