Nsight Systems, remote connection problem from Windows host to Linux target

I am on Windows 10, trying to profile a program on a Linux server with GPUs using Nsight Systems. However, I cannot connect to the remote machine. When I select password-based authentication method, Nsight Systems shows me this error:

image

I have reconfigured OpenSSH service, added my public key, and tested ssh from available CLIs (PowerShell, gitbash, and cmd) without any problem. Also the public-key authentication option is disabled, and I couldn’t test it:

image

Hi @amir.sojoodi , what’s the version of Nsight Systems were you using?

Hi! Nsight 2021.2.1

Hi @amir.sojoodi,

Could you help collecting logs to help investigation?

Steps:

  1. Save nvlog.config (511 Bytes) to “C:\Temp\nvlog.config”
  2. Set a system-wide environment variable “NVLOG_CONFIG_FILE” to “C:\Temp\nvlog.config”:
    image
  3. Restart your system.
  4. Open Nsight Systems GUI, connect to your Linux target system. After hitting the error you mentioned, close Nsight Systems GUI.
  5. There should be a log file under “C:\Temp\nsight-sys.log”. Share this file to us and we’ll see if we can figure out what’s wrong.

Thanks,
Liuyi

nsight-sys.log (23.5 KB)
Thanks for your help Liuyi.
The log file is attached.

Hi @amir.sojoodi, thanks for the log. Were you connecting to the target system with a password or without?

I’d like to connect to the remote machine using ssh public-key authentication, but that’s not enabled in the GUI as I mentioned first. However, I can connect to the server with nvvp using ssh public-key. Also, connecting to the remote machine on the command line using either public-key authentication or password works just fine.

We currently does not support public-key based authentication for Linux targets, this is on our roadmap and will be supported in the future. Your feedback will help us prioritizing this feature.

As to password-based authentication, could you verify if the target system allows it? The debugging log you shared is indicating the target system does not allow password-based authentication. Could you check if /etc/ssh/sshd_config has PasswordAuthentication yes?

Thanks for your answer. That would be very helpful if you can provide that support.

I just tried again to ssh to the remote server with password and it was ok, however the sshd config file is not readable by me, as it is a shared server. So, I couldn’t verified that.

@amir.sojoodi If possible, could you add -vv switch to your ssh command line when you login to the remote server with password, and share the output? For example ssh -vv user@host.

If there are any confidential information from the output you could hide them, we just need the general output about authentification methods.