Nucleus server is not working at localhost, Ubuntu

After installation both cache and nucleus server from omniverse launcher (following the current instruction), I am facing the issue that I can’t reach localhost. In the launcher I see:

When I try to open settings through the hamburger menu, I can’t open the page in the browser and settings are unreachable:

During the installation the firewall and VPN were inactive. The system is Ubuntu 20.04 and I installed the newest versions of each software.

Interestingly enough, when I open Isaac Sim and log into the Nucleus Server in my organization, then everything is working as intended, but localhost still remain unreachable.

After the installation I used Cleanup Tool and install it again, but didn’t help.

Can you please validate all the services, especially auth and discovery, are running on your localhost?
You get to this from the hamburger menu->settings.

As I wrote.
If I try to open settings (from hamburger menu) I receive the message:

Which means that I cannot open the settings using hamburger menu.

Is there any other way to validate this?

just curious, do you get the same message using Chrome or Edge?


The same for all browsers:

do you happen to have a print out of the terminal/console/log?

Launching an omniverse launcher from the terminal results in no logs, however I have something in ~/.nvidia-omniverse/logs. The content of this folder is in the attachment: (289.4 KB)

just an observation - I am seeing a “Failed to load GDPR” error that results in a Http error 403 but not sure if it’s related

and if it’s the case, I found this post from two years ago that may be relevant - Omniverse Launcher cannot be launched - #4 by rvinobha

If you’re hitting this error, it’s likely your port is blocked somehow.
You’ll need to try and open the ports Nucleus needs.
It’s also possible Nucleus didn’t install correctly.
You can try uninstalling, then reinstalling and rebooting to see if that works as well.

It turns out that antivirus blocked it.

I am glad you figured out it was Antivirus