Unable to connect to Nucleus Localhost

Hello,

I am unable to connect to localhost on my computer when I “Add Local Nucleus Service”.
Screenshot 2023-07-14 164415

I have tried many potential solutions reading other posts with similar issues on this forum, but nothing worked.

I have tried:

  • Following Documentation on installing Workstation
  • Making sure the suggested ports are not taken by my pc
  • Restarting omniverse launcher and reinstalling local server
  • Updating “Cache” to latest versions and other appropriate Omniverse app software
  • Running Omniverse Launcher as admin and recreate local server
  • Inputting correct credentials

Additionally, most of the links posted by users on the forums which link to Nvidia resources are not working.

Platform:

  • Windows 11

Can you please post an image of the nucleus tab in launcher.

Also can you please go to the hamburger menu under the nucleus tab and go to settings, that should launch system monitor. Can you please validate all the services are running?

Is this an update or new install of nucleus?

I have been experiencing the same issue since last Friday. For me, I am getting “This site can’t be reached” error when selecting the setting under the nucleus.

Besides, I’ve been unable to access any documentation related to the Omniverse extension.

After relaunching the Omniverse launcher, I’m now encountering a backend error from localhost:3080.

Hi @dlindsey,

Here is the image of my Nucleus tab in Launcher:

All of the services are green when running the system monitor.

As far as I can tell this is the latest install of Nucleus.

Hi @dlindsey,

I have an older version of Local Nucleus Server running on another PC and that seems to work fine (v.2022.4.2). Is there a way where I can downgrade Nucleus from v2023.1.0 to this older version until this issue gets resolved?

I’m having the same problem… I tested 2 month ago on my Windows PC with version 2022.4.2 but when I switch to Linux and installed 2023.1.0 it’s showing the same problem as yours.

The documentation issue should be fixed now and docs should be accessible now.

As for this error, it looks like something didn’t install completely. Please uninstall and reinstall nucleus.

Also please validate your are installing nucleus on a local drive.

Can we please get the logs for the current version having issues?

You should be able to install the old version by running this command

omniverse-launcher://install?slug=nucleus-workstation&version=2022.4.2

Hi,
Thanks for the feedback. I looked at the admin file and found for some reason it didn’t save my username and password but only saved the default name: admin, psw: admin. After trying this I could finally log in yesterday… sorry I didn’t save the log.

Hi @dlindsey,

The solution that @yujing.liu provides allows me to log into the localhost server.
No matter what credentials are entered at server creation, the localhost only accepts:

  • Server name: localhost
  • Username: admin
  • Password: admin

I am not sure where to find this admin file and locate the saved passwords to confirm @yujing.liu post, but the solution works.

I will stick with the latest version of Nucleus and wait for a future fix to resolve this issue.

On a related note to @Ripeg issues with broken links, under the Omniverse Navigator the “Link to Drivers” currently returns a 404 error. I tried to use this link to check for updated drivers.

Attached are all the log files.
logs.zip (14.2 MB)

I am having the same problem. I never get asked for a server name, I click Add Server, and it asks me to authenticate.

I went through the setup once, then never could connect to the server, so I uninstalled / reinstalled Navigator. How do you uninstall the server so it starts over?

Edit: It was asking for Server Name, I can’t read gray text on a white background. I opened magnifier and saw it was asking for Server Name, and admin / admin worked.

1 Like

As admin, you can create new user account as well, so you don’t have to be logged in as admin

I don’t mind being admin / admin. I didn’t know what user name to use till I read this post.

Thanks

1 Like