Localhost Nucleus Server broken


Recently, the localhost Nucleus server disappeared from the list of my server, and thus also my access to standard assets.
I tried adding localhost manually, and also de- and re-installing the Local Nucleus Service. This makes localhost reappear however, when I try to access it, it reports “Cannot connect to the server (INTERNAL_ERROR)”.
I also tried uninstalling and reinstalling Oniverse Launcher, but all settings seem to persist between installations.

I’m grateful for any help :)

Edit: This is the launcher log
launcher.log (257.9 KB)
The System Monitor, however, does not open when I try to start it from the Start menu.

@d.rausch i have not experienced this yet as a fellow user. however, if you could upload the launcher log for the devs/mods to do further assessment, it may help provide them with additional context. you can find the .log with the following path:

  • Windows - %userprofile%\.nvidia-omniverse\logs\launcher.log
  • Linux - ~/.nvidia-omniverse/logs/launcher.log

in addition, can you go to the OV system monitor to see if all the services are running fine (providing screenshot would be helpful here as well)?

Looking at your logs, it is full of errors that your system cannot connect to your network, your internet, your localhost, etc. The connections are being refused, the network is not even found. Something is very wrong.

[error] Error: [localhost] (NUCLEUS) service is not accessible. Please check your network connection and the server status with administrator.

  1. completely restart the computer and the router. Make sure you have a strong internet connection.
  2. Start Launcher. Make sure you are logged in. Better still log out and then log in again.
  3. Try to start an App, like USD Composer or Issac Sim. Does that work ?
  4. You said “thus also my access to standard assets” ? What does this mean ? There is nothing in Nucleus you need to use Omniverse. There are a few demos we install, but nothing is needed. Not even Nucleus.
  5. If you want to use Nucleus (which is optional), and you cannot connect to it, delete and and re-install.
  6. Reboot your entire computer.
  7. If Nucleus is still not working, click on Settings (see photo 1) and then check your services are running
  8. You can hit RESTART ALL and try that, or download the logs for any service not running

Thanks for the suggestions.

Sadly, non of those changed anything.
I can start IsaacSim and use it normally. However, we are using the IsaacSim standard warehouse assets for our current demo, which are located at omniverse://localhost, and thus cannot be found anymore.

I managed to fix the issue.
I had to uninstall the Omniverse Launcher, and also remove the folders %USERPROFILE%/.nvidia-omniverse and %USERPROFILE%/AppData/Local/ov
This allowed me to install everything from scratch, and now I have access to omniverse://localhost again

Great. Glad to hear. That was going to be my next suggestion.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.