Cannot connect to Nucleus Localhost


I cannot connect to localhost on Nucleus. Also, there are no alive services in http://localhost:3080/.
I attached the logs file and screenshots here: (1.7 MB)

Thanks in advance for your kind help!

@xwang2463 if you were to click on Launch, do you see any updates to the services in the OV System Monitor?

also, is this a personal machine or inside a corporate network? trying to see if it’s related to a stricter firewall/port configurations.

@Simplychenable When I clicked on Launch, it seems like there are no updates on System Monitor Logs as shown below:

This is a computer in our lab, which is connected to our university network.

this may be related to how the way uni had set up OV. do you know if there are other users in the lab having similar issues?

Our lab has another ubuntu computer which is also connected to our university network. But that computer is doing well.

What running services does your system monitor show?

@dlindsey this screenshot was pulled from his zip file, it appears to be empty:

not sure about the other machine he mentioned that’s working properly, though.

This means no services were installed or available on the system at all.
So it looks like the whole install is failing.

@xwang2463 , can you please double check in your Library Path (listed in launcher) to make sure that Nucleus workstation did in fact install?

Please also make sure you don’t have ports blocked on your system. Your log is showing connection refused on the discovery port 3333

Hi, @dlindsey Thanks for your reply. I believe I have installed the nucleus workstation correctly. Here is the screenshot:

How could I turn on the connection for the discovery port 3333?

Check in your Library Path and make sure you have a Nucleus workstation directory.
As for making sure port 3333 is open, you’d have to check out your firewall settings to make sure it’s not blocked or used by something else.

I think the Nucleus workstation directory is installed properly:

Still working on whether I can change firewall settings to open port 3333.

Can you try and launch the Discovery Service /Discovery Service/omni-discovery-service.exe directly, to see if you’re getting any errors?

Here is the screenshot:

that’s interesting. It looks like it’s running properly. Can you try rebooting your system and going to system monitor again?

Here is the system monitor log after reboot:
System Monitor.log (30.1 KB)