Numba/python error during fresh installation

Hi, I’m trying to setup isaac from scratch using the omniverse system. When I first launch the application I get an error because numpy==1.21.2 cannot be used with numba==0.54.0. When run Isaac shows

2021-08-25 08:37:48 [7,426ms] [Error] [carb.python] [py stderr]: RuntimeError
2021-08-25 08:37:48 [7,426ms] [Error] [carb.python] [py stderr]: : 
2021-08-25 08:37:48 [7,426ms] [Error] [carb.python] [py stderr]: module compiled against API version 0xe but this version of numpy is 0xd
2021-08-25 08:37:48 [7,426ms] [Error] [carb.python] [py stderr]: 

This can be “solved” by manually installing numpy==1.20.3 via python.sh -m pip install. IDK if it’s just me but I’ve tried this on a fresh system.

Moreover, while installing the requirements I get the following

ERROR: aiobotocore 1.2.0 has requirement botocore<1.19.53,>=1.19.52, but you'll have botocore 1.19.53 which is incompatible.
ERROR: tensorflow-gpu 2.3.1 has requirement numpy<1.19.0,>=1.16.0, but you'll have numpy 1.20.3 which is incompatible.

Yes, unfortunately in the previous release of isaac sim we did not forcefully pin the version of numpy (and other dependencies) so dependencies installed at runtime pull the latest which in time became incompatible with existing packages. This will be resolved with the next release. All pip dependencies will be shipped with isaac sim so nothing in installed at runtime.

manual installation or updating is a solution for the time being.