Nvidia 455 driver DPMS doesn't turn monitor back on

There seems to be a bug in the linux 455 branch of drivers where if the screen is turned off and turned back on again, there is no display signal. If the screen is off for only a short period, it doesn’t always happen. I am using Gigabyte RTX 2070 WF3 8G graphics card and an LG OLED65B7V connected via HDMI cable. It has been working fine until I updated to the 455.45.01 driver. Other 455 and 460 drivers have the same issue. I rolled back to 450.80.02 and the problem is fixed, but I would like to use a newer driver so I can update to the latest linux 5.10 LTS kernel.

If the TV is turned off and back on, the signal does not come back on it’s own, but any of the following can be done to get it back:

  1. Restart the X Server
  2. Unplug the HDMI cable and plug it back in again
  3. Run the following command : xset dpms force off;xset dpms force on

Looking through the changelog in the 455 driver series, the only change that looks like it could be related is : Fixed a regression that allowed displays to enter DPMS mode even when DPMS is disabled in the X server settings.
Could the fixing of this bug have caused another, or is it somethig unrelated to this bug?

I have been browsing the arch linux forums and there seem to be many reports of the same thing, and they are all version 455 drivers:

plus post with ID 260159 (I can only add 3 links to this message)

I have tried changing the HardDPMS and UseHotplugEvents settings in the xorg.conf, but to no avail.

As I want to use the 5.10 kernel, I am staying with the 460 driver, and have added a key binding to run ‘xset dpms force off;xset dpms force on’ so at least it is easy to turn the screen back on without having to unplug the HDMI cable.

2 Likes

I have the same problem with a GeForce RTX 2060 Mobile and nvidia driver 460 (OpenSuse 15.2, kernel 5.3.18) on my external display. With 450 all is running fine, with 460 I get a blank screen after start of X or when the display goes into energy saving mode/is turned off. Although the external display is always recognized by the system. But only unplugging the HDMI cable and plug it back in or switching to another input port on the monitor and back to HDMI wakes it up again.

As I can see, you have a 4k display, too, right? Have you tried to lower the display resolution? My external display normally runs at 3840x2160@60Hz. When I switch to a lower resolution or to 30Hz, the display is waking up normally. So imho it seems to be a problem with 4k resolutions.

I normally run at a resolution of 3840 x 2160 and see the issue where the screen doesn’t returns after going to sleep. I switched to 1920 x 1080 and the problem did not occur, so it looks like you are right and it only happens at 4k resolution.

I’ve had the same problem using RTX 2070 and an LG 27 UL650 monitor with Linux Mint Cinnamon. I noticed that everybody with this problem, including me, was using an HDMI cable to connect the card to the monitor. On a hunch I tried connecting through a displayport. Voila!!! Problem solved. The monitor now not only wakes up when I move the mouse or press a key, but it does so faster than it did when was using the old 450 driver. I would guess that the problem might be that I was using a monitor that doesn’t have speakers and when the HDMI audio channel failed to connect to speakers after several attempts, the handshake timed out. But that’s just a guess. I’m not an expert on these things.

I have the same problem, running 460 drivers, kernel 5.10.
Rebooting or pulling / inserting the HDMI cable from the monitor brings the 2nd screen back to life.

This did not happen prior to updating my drivers to 460

Any chance that Nvidia will resolve this issue?
With the latest 460.56 driver I still get a blank screen on 4K HDMI.

Also experiencing this issue on 460.39-0ubuntu0.20.04.1 drivers with kernel

Linux br-workhorse 5.4.0-66-generic #74-Ubuntu SMP Wed Jan 27 22:54:38 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Setup is two 4k displays via DP connections, one 1920x1200 display via DVI connection and one 4k TV via HDMI. Only the HDMI has issues.

Thanks for the tip about using xset to toggle dpms, re-plugging the display or toggling it via KDE settings messes with window placement, whereas the xset method doesn’t.

Any updates on this issue?
I have a NVIDIA GeForce GTX 1050 Ti Mobile running nvidia 460.67-5 driver @ 5.11.11-arch1-1 and I´m facing exactly the same issues. Lowering from a 4k resolution to 1920x1080 “solves” the problem.