Dpms turns monitor off and then back on again

Hi

I have a 1070 card with a MSi Optix MAG monitor. Since I switched to this monitor (and displayport), DPMS doesn’t work. If I put dpms standby at 60 seconds it turns off after 60 seconds, but then 10-20 seconds later turns back on again. (This is regardless of timer/disabling suspend/off modes).

When this happens I see this in the xorg log:
[ 454.316] (–) NVIDIA(GPU-0): DFP-4: disconnected
[ 454.317] (–) NVIDIA(GPU-0): DFP-4: Internal DisplayPort
[ 454.317] (–) NVIDIA(GPU-0): DFP-4: 1440.0 MHz maximum pixel clock
[ 454.317] (–) NVIDIA(GPU-0):
[ 454.907] (–) NVIDIA(GPU-0): Microstep MSI MAG272CQR (DFP-4): connected
[ 454.907] (–) NVIDIA(GPU-0): Microstep MSI MAG272CQR (DFP-4): Internal DisplayPort
[ 454.907] (–) NVIDIA(GPU-0): Microstep MSI MAG272CQR (DFP-4): 1440.0 MHz maximum pixel clock
[ 454.907] (–) NVIDIA(GPU-0):
[ 455.052] (II) NVIDIA(0): Setting mode “NULL”
[ 455.116] (II) NVIDIA(0): Setting mode “DP-2: nvidia-auto-select @2560x1440 +0+0 {AllowGSYNCCompatible=On, ViewPortIn=2560x1440, ViewPortOut=2560x1440+0+0}”

nvidia-bug-report.log.gz (362.5 KB)

This happens both with harddpms on and off. Any ideas?

I’m running a monitor with 165hz refresh rate at 2560x1440 (which works fine with latest drivers 👍), so I’m not sure using hdmi is an option?

(With my old monitor with DVI at 60hz, dpms worked fine)

Any feedback on this?

Can you please try running xev -event randr in one terminal and then triggering DPMS with something like sleep 2; xset dpms force off in another terminal? I’m curious whether your new monitor is generating a hotplug event in response to power saving.

The messages in your Xorg log indicate that some X client is requesting that the monitor be turned back on, which I could see happening if the monitor is generating hotplug events.

You might want to dig through the monitor’s OSD menus to see if there’s a power-saving option you could try disabling.

Hi

I just checked that, there is no extra output other than “Outer window is 0x6e00001, inner window is 0x6e00002”. Triggering the dpms command does turn off the monitor, then after a bit it turns back on, but the output in the xev window stays the same.

I have checked, unfortunately the OSD settings is windows only. (This is a MSi Optix MAG series), but I have a linux command line tool (third party, https://github.com/couriersud/msigd/) for it as well, neither one has any power saving options.

I’ve figured this out, it’s kscreen waking it up again. I’ll make a bugreport upstream.

1 Like