Nvidia SDK manager does not run!

I’ve installed SDK manager on my windows laptop, using Ubuntu. But as I want to run it, I face this error: “The futex facility returned an unexpected error code.”.

I want to try to reboot my Jetson nano which does not turn on at all, but I am stuck!


Hi pghodraty,

What is this exact meaning? Are you using Windows or Ubuntu as your operating system?
Or you use Windows PC but install Ubuntu with VM/docker?

Are you using the devkit or custom board?
Does your Jetson Nano work normally before?

I am using Windows PC but install Ubuntu with VM.
I think it is devkit as it was bought from Nvidia. No one could run it before at all. Only one time I could turn it on using a micro SD image which after doing the initial configures, it turned off and never turned on again. I tried different versions of images but nothing worked!

Hi pghodraty,

Please use standalone Ubuntu18.04 as your host PC.
VM might cause unstable connection with your board because there are several reboots during flash.

You could refer to the following instruction to flash the board with SDKM.
Install Jetson Software with SDK Manager :: NVIDIA SDK Manager Documentation

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.