Nvidia-settings - Unable to load info from any available system

Hi there. I have just installed Ubuntu 16.04.
I am using 7 gpus 1080ti and using only ssh connection (no display connected)
Installed fresh driver sudo sh NVIDIA-Linux-x86_64-440.83.run`
(full steps i wrote here: https://askubuntu.com/questions/1225849/nvidia-settings-complex-problem)
THE PROBLEM - i can’t run nvidia-settings, have error
Unable to load info from any available system

Also i can’t use
sudo prime-select nvidia
Info: the current GL alternatives in use are: [‘mesa’, None]
Info: the current EGL alternatives in use are: [‘mesa-egl’, None]
Error: the installed packages do not support PRIME
Error: nvidia mode can’t be enabled

±----------------------------------------------------------------------------+
| NVIDIA-SMI 440.82 Driver Version: 440.82 CUDA Version: 10.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 108… Off | 00000000:01:00.0 Off | N/A |
| 0% 19C P8 10W / 250W | 42MiB / 11177MiB | 0% Default |
±------------------------------±---------------------±---------------------+
| 1 GeForce GTX 108… Off | 00000000:02:00.0 Off | N/A |
| 0% 17C P8 9W / 250W | 8MiB / 11178MiB | 0% Default |
±------------------------------±---------------------±---------------------+
| 2 GeForce GTX 108… Off | 00000000:04:00.0 Off | N/A |
| 0% 18C P8 10W / 275W | 8MiB / 11178MiB | 0% Default |
±------------------------------±---------------------±---------------------+
| 3 GeForce GTX 108… Off | 00000000:05:00.0 Off | N/A |
| 0% 23C P8 12W / 250W | 8MiB / 11178MiB | 0% Default |
±------------------------------±---------------------±---------------------+
| 4 GeForce GTX 108… Off | 00000000:06:00.0 Off | N/A |
| 0% 17C P8 10W / 280W | 8MiB / 11178MiB | 0% Default |
±------------------------------±---------------------±---------------------+
| 5 GeForce GTX 108… Off | 00000000:08:00.0 Off | N/A |
| 0% 20C P8 9W / 320W | 8MiB / 11178MiB | 0% Default |
±------------------------------±---------------------±---------------------+
| 6 GeForce GTX 108… Off | 00000000:09:00.0 Off | N/A |
| 0% 22C P8 17W / 320W | 8MiB / 11178MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 923 G /usr/lib/xorg/Xorg 25MiB |
| 0 1805 G compiz 13MiB |
| 1 923 G /usr/lib/xorg/Xorg 5MiB |
| 2 923 G /usr/lib/xorg/Xorg 5MiB |
| 3 923 G /usr/lib/xorg/Xorg 5MiB |
| 4 923 G /usr/lib/xorg/Xorg 5MiB |
| 5 923 G /usr/lib/xorg/Xorg 5MiB |
| 6 923 G /usr/lib/xorg/Xorg 5MiB |
±----------------------------------------------------------------------------+

nvidia-settings is an application for graphics settings. If there’s no Xserver running on an nvidia gpu (like when run over ssh), there’s no settings to be done. Expected.

But is any way to control fan speed of gpu? I need to set always 80% fan speed. Find that i can do this with nvidia-settings

Looking at the nvidia-smi output, you have Xservers running on the gpu. You should be able to use nvidia-settings by setting the correct DISPLAY and XAUTHORITY values, like running as root:
DISPLAY=:0 XAUTHORITY=/run/user/111/gdm/Xauthority nvidia-settings
use ps aux |grep X
to get the correct value for XAUTHORITY (what comes after --auth)

Thanks for reply friend!

ps aux |grep X
root 923 0.0 0.7 341272 116756 tty7 Ssl+ апр17 0:07 /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
admin 6393 0.0 0.0 21292 960 pts/2 S+ 18:37 0:00 grep --color=auto X

tried:
sudo DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/ nvidia-settings
and
sudo DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/:0 nvidia-settings

output is:
No protocol specified
Failed to connect to Mir: Failed to connect to server socket: No such file or directory
Unable to init server: Could not connect: Connection refused

ERROR: The control display is undefined; please run nvidia-settings --help for usage information.

Should be correct:
https://forums.developer.nvidia.com/t/nvidia-settings-on-headless-server/53758/4?u=generix
Try getting a root shell first using
sudo -s

1 Like

OMG! I searched all web to find this solution!

DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/:0 nvidia-settings -a [gpu:0]/GPUFanControlState=1
DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/:0 nvidia-settings -a [fan:0]/GPUTargetFanSpeed=75

Thank you very much!!